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Introduction User Manual

About PiXELS:3D

PiXELS:3D is an integrated suite of professional tools for creating and animating 3D
characters and visual effects. PiXELS:3D gives you full control of every step in the
production process:

• Easily build and edit organic models in real-time

•  Realtime Shaded Preview

• Create and apply textures and materials

• Position objects and lights within a scene

• Create realistic movements for all objects 

• Produce broadcast quality renderings of your animations

We thank you for choosing PiXELS:3D and look forward to providing you with powerful
and efficient solutions for all of your creative needs. Should you require help, please contact
our technical support desk at the number below. 

Customer Support: 9 am–6 pm Monday–Friday (pst)

(619) 220-4902 

Fax us at:

(619) 299-4821 

E-Mail: support@pixels.net

URL: www.pixels.net or www.pixels3d.com

System Requirements

• PowerPC based computer running MacOS 8.0 or later
• 16 MByte available RAM (Complex scenes may require more memory)
• 30 MByte of hard disk space
• Color monitor capable of displaying at least 800 x 600 pixels:3d (A large monitor

is a definite advantage, since it helps distinguish details of the wireframe models
for precision work.)

Recommended System

• PowerMac G3 @ 266+mHz
• 128 MByte available RAM
• 1GB of hard disk space for rendered images and texture maps
• 21” color monitor
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Legal Notice
The software described in this manual is furnished under license and may only be used or
copied in accordance with the terms of that license. All rights reserved. ©1999 Pixels
Animation Studios, Inc. Cover art by Clyde Duensing III ©1999. Cover design by T.S. Wilson.

Installing PiXELS:3D

1. Insert the PiXELS:3D CD in your CD ROM drive.

2. Double click on the PiXELS:3D_3.0_Install icon and follow the instructions.

3. There are optional files included on the PiXELS:3D CD. If you have room on your hard
drive, you should copy these files into your PiXELS:3D folder.

• PiXELS:3D utility files
• Shaders and texture maps
• Sample PiXELS:3D models
• Optionally, a Read Me file for late-breaking information about PiXELS:3D

To begin using PiXELS:3D:

1. If you see a Read Me file, double click on the icon to open it. It describes last minute
changes which may not be included in this guide.

2. Double click on the PiXELS:3D application icon inside the PiXELS:3D folder. 

3. The first time you use PiXELS:3D, you will see a dialog box asking for your name, your
company name, and a Software Key. The Software Key can be obtained by following the
instructions shown in the dialog. After obtaining your Software Key, type in the requested
information, and click Register to imbed it in your PiXELS:3D file. The User Name and
Company Name will appear on the splash screen each time you launch PiXELS:3D.

4. If PiXELS:3D is installed on a computer that does not have the proper system
requirements (for example, insufficient memory or an unsupported processor), the
application cannot be opened. If this happens, a dialog box will present an error message
explaining the problem.
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About this Manual

This manual explains everything you need to know to use PiXELS:3D. If you are new to 3D,
it is highly recommended that you read the “3D Basics” chapter in the Self Training
Workbook before beginning to learn the software.

In addition, we assume that you are familiar with the use of the mouse, as well as the
Macintosh interface, icons and pull down menus. Basic skills common to all Macintosh
applications like clicking, dragging, scrolling and opening files are not explained within
these pages, but are covered in detail in the manuals that came with your computer.

This manual is broken into five sections: Views, Menus, ShaderMaker, Tools and Constraints.
Each section contains a list of all tools and features with step-by-step instructions for
performing their related functions.

A Glossary at the back of the manual provides definitions to terminology used in this guide.
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Views
The viewing area of the PiXELS:3D display by default contains four viewing panes: Top,
Front, Right, and Camera. The Top, Front and Right views present a 2D representation of
the object(s) from the corresponding viewpoint. The Camera view is unique in that it
represents the point of view of an object as it exists in the applications space. As you
manipulate and edit an object, you can see the changes occur in each window.

Each viewing pane has a number of controls that you can access. Let’s look at each of
these.

Sizing

Any of the four viewing panes can be resized in one of two ways. The first is to
click on the “+” sign that is located where all four viewing panes meet in the
center of the interface. While holding the mouse button down, you can drag this
around to resize all four views simultaneously. Holding the Option key down while

clicking on the “+” sign, will reset all four views back to their default sizes. The second way
to resize the views is to click on any view’s Zoom Box.

Zoom Box

The Zoom Box can be found in the upper right hand corner of each view’s title
bar. It looks like two intersecting squares. Clicking in this Zoom Box fills the
viewing area with that view. Any view can be set to fill the viewing area by clicking
in its Zoom Box, including the Camera view. If you hold the Option key down

while clicking in a Zoom Box, the view will zoom horizontally, but not vertically. This can be
useful when working on wide objects or when using the Twist & Taper view.

Deactivate

Any view can be deactivated by clicking on the first icon from the left in that view’s
title bar. The title bar will dim and that view will no longer refresh, speeding the
refresh of all other views.
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Perspective

Perspective can be turned on or off by clicking on the second icon from the left in
that view’s title bar. When perspective is on, PiXELS:3D will show objects
“realistically” from that view’s particular point of view. The edges of objects will
converge on a central vanishing point and objects closer to the viewer will appear

larger than objects farther away. Any view can have perspective either on or off. When
modeling, it is usually better to work without perspective in the top, front and right views.

Grid

Click on this icon to show or hide a visible grid in the top, front or right views. The
dimensions of the grid can be set in the View Options dialog, or by using the grid
size command in the Command Line window (which can be opened by selecting
Control > Command).

Zoom In/Out

Use this icon to zoom into or out of a view. To use, click on the icon and drag the
mouse up to zoom out or down to zoom in. The distance from the original mouse
click controls the speed of the zoom. In the Camera view, zoom moves the
Camera forward and back along the line of sight.

Pan

Use this icon to pan around a view. To use, click on the icon and drag the mouse
up, down, left or right. The view will move in relation to the mouse. The distance
from the original mouse click controls the speed of the pan.

Orbit (Camera view only)

Use this icon to orbit the Camera around the interest. To use, click on the icon
and drag the mouse up, down, left or right. The Camera will orbit in relation to the
mouse. The distance from the original mouse click controls the speed of the orbit.

8
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View Options

Each of the four viewing panes have a number of different options that can be
set. To access the View Options dialog box, click on the name of the viewing
pane that you want to effect. The name can be found in the left corner of the
bar at the top of each viewing pane. Any changes that you make to the View

Options dialogue box are saved with the current scene and will be reinstated when that
scene is loaded from disk.

Let’s look at each of the options that can be set for the View Options dialogue box.

View

When clicked on, this pop-up menu lists optional views that the selected viewing pane can
display. Any view except the Camera view can be changed. You can select from the
following view options: 

Top View
Front View
Right View
Schematic View—discussed at the end of this chapter
ShaderMaker View—discussed at the end of this chapter
Twist & Taper View—discussed at the end of this chapter

9
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Shaded Preview

Shaded preview displays an object preview, complete with textures, and transparency.

Depth Cue

The Depth Cue option draws wireframes which fade to the Background as the distance from
the Camera approaches the Outer Radius.

Inner Radius

Distance from the Camera where wireframes begin to fade.

Outer Radius

Distance from the Camera where wireframes are 100% Background.

Background

Every view has a background color. Clicking in the box to the right of the Background title
will open the Apple color picker, allowing you to set the background color.

Image

Any view can also have a PICT image as a background. This is helpful when modeling
something from a scanned image (i.e. take photos of an object from the top, front and right)
or for placing a computer model into a real scene. PICT sequences can also be used for
rotoscoping. Click on the box to the right of the Image check box to open the Texture
Manager dialog. See the ShaderMaker section for more details.

Visible Grid

When checked, this option shows this viewing panes grid. When unchecked, the grid will be
hidden.

10
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Grid Size

Sets the size of the visible grid in PiXELS:3D units. The Visible Grid option must be
checked before the grid can be seen.

Grid Color

Clicking on this box opens the Apple color picker, allowing you to set the color of the grid
lines.

Grid Major

Clicking on this box opens the Apple color picker, allowing you to set the color of the center
or origin grid lines (the ones which intersect at 0,0).

Visible Axis

When checked, this option shows the axis reference icon in the lower left corner of this
viewing pane. When unchecked, the axis reference icon will be hidden.

Clipping

When checked, portions of objects which are closer than Near Plane or farther than Far
Plane are invisible or clipped. This makes working with complex scenes much easier,
allowing you to focus on a single object or even a portion of that object.

Absolute/Relative

When the Absolute option is selected, the clipping planes are considered to be absolute
(world space) coordinates.
When the Relative option is selected, the clipping planes are considered relative to the
Camera, so as you dolly in and out, different portions of the scene appear and disappear.
These options are a Radio Group, which means selecting one will automatically deselect the
other. Both cannot be selected at one time.

Near Plane

When Relative is selected, this value defines how close an object can be to the Camera
before being clipped.
When Absolute is selected, this value defines the minimum position where, along the
orthogonal (perpendicular) axis to this viewing plane, objects are visible.

Far Plane

When Relative is selected, this value defines how far an object can be from the Camera
before being clipped.
When Absolute is selected, this value defines the maximum position where, along the
orthogonal (perpendicular) axis to this viewing plane, objects are visible.

Show Links

Shows the Links between the 'parent' and 'child' objects.

Show Path

Shows the Links between the object  andits path.

11
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Drawing Options

The Drawing Options palette has two collums. The 'Selected Objects' and 'Unselected
Objects'. Both have the same options available. 

These are:
Hull: Shows a wire mesh outline of objects. 
Surface: Draws the actual spline curves that make up a shape. This is the most accurate
representation of a shape, but will take more time to draw. 
CVs: Display's the Control Vertices. 
Center: Shows the objects center, and X , Y , and Z orientation. 
Normals: Shows the surface normals of the objects. 
Bounds: Shows the Bounding boxes of the object. 
Spline: Shows the central Bezeir curve of the objects.

12
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Special Views

Each of the viewing panes for the top, front and right views can display one of the following
special views: The Schematic View, The ShaderMaker View or The Twist & Taper View.
Let’s examine each of these.

Schematic View

The Schematic View allows you to view the hierarchical structure of your scene. Each object
is displayed as a small box, with its name printed inside the box. To the left of the name is
the object’s wireframe color. Objects can be selected from this view, making object selection
much easier in complex scenes. The arrows that connect each object are color coded. Green
arrows show objects that are linked together with a parent / child relationship, blue arrows
show an object’s point of interest, red arrows show a motion path that an object will follow,
while magenta arrows point to a lattice that will deform an object.

ShaderMaker View

The ShaderMaker View allows you to view the hierarchical structure of the currently
selected object’s shader nodes. Clicking on a node will open the options dialog for that
node. Clicking on the first node will open ShaderMaker. Having the ability to see the
different nodes that make up a shader, and being able to access the dialogue box for any of
them, allows you to quickly make changes to a shader. 

13
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Twist & Taper View

The Twist & Taper view is a powerful feature for freeform reshaping of objects. It allows you
to scale and rotate part of an object by moving four control points along the objects central
spline. 

The Twist & Taper View displays a blue (upper) curve that defines the object’s scale at any
given point from front (0) to back (1) and a red (lower) curve that defines the twist.
Dragging any point on the upper curve will taper, flare and bulge the selected object, while
dragging on the lower curve twists it.
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File: New [ N]
Creates a new, unnamed PiXELS:3D file using default settings to begin model creation.

1. Choose New from the File menu or type N. 
2. An untitled window appears on the screen with the tool palette on the left, ready

to begin. A typical session begins by choosing or importing a shape. (see Tools >
Shape or File > Import.)

A new, untitled scene.

17

PiXELS:3D v e r s i o n  3 . x

f
i
l
e

m
e
n
u
s



File: Open [ O]
Opens an existing PiXELS:3D file and displays it on the screen. Closes the file on the screen
before opening another.

1. Choose Open from the File menu or type O.
2. A dialog box appears listing files in the selected folder that can be opened from

PiXELS:3D. Select a file name from the list and click Open or click Cancel to
abort.

3. A PiXELS:3D file can also be opened directly from the desktop by double clicking
its icon.

The standard Apple open dialog.
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File: Import
Merges external model or motion data with the current PiXELS:3D scene.

1. Choose Import from the File menu and drag the mouse to select and highlight
the desired format.

2. Find the folder in which the file to be imported is located.
3. Highlight the desired file, and click Open. PiXELS:3D opens the file and displays

it on the screen.

Illustrator Import Options

Linearize Spline

When checked, converts Bézier splines to linear splines.

Flatness

Sets the number of subdivisions used when converting Bézier splines to linear splines. The
lower this value, the smoother your curves will appear. The value is a tolerance in degrees.

Extrude Imported Art

When checked, all of the imported outlines will be extruded. Trim surface end caps are
automatically created and placed. Compound objects are also detected, so holes in letters are
created automatically. This is very useful for logos and text.
See the Shape > Extrude tool in the Tools section for more details about the various extrude
options.
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Importing Dynamation Files

Dynamation is Wavefront’s high-end particle animation system for Silicon Graphics
workstations. Although some users won’t have access to this system, the format which it
exports provides a very straightforward way of describing generic particle data. The
following information is provided for those of you who wish to create your own
Dynamation files.

A Dynamation file is simply an ASCII file containing the position and, optionally, directional
vector information for any number of particles. Each file contains only one frame of
information, so more often than not, multiple files will be needed. Each file has a numeric
suffix to define its position in time. A typical file name might be something like
“SwarmOfBees.00001” where 00001 would be the frame number.

The Dynamation File Format

A simple Dynamation file may look something like this:
4  6  5  0  0  1
This is a particle definition. The first three numbers define a particle’s position in space (x, y
and z respectively.) The next three numbers represent a directional vector. This is simply a
line which points in the direction the particle is heading. Because lines need at least two
points to properly define them, in a direction vector it is assumed that the first point in the
line is {0, 0, 0}. Currently the directional vector is assumed to be normalized. In other words
the total length of the line is 1 unit. 

For each particle in a scene there should be one particle definition like the one above. Each
particle definition, except the last one, should be followed by a return character.

When PiXELS:3D imports a Dynamation file, it duplicates the currently selected object or
hierarchy and places it according to the x, y, z information contained in the Dynamation file.
For each particle definition a new copy of the selected object is created. Once all the particle
definitions are read, PiXELS:3D goes to the next file in order. No more copies of the object
are created. Instead the positional information is added to the object’s fCurves. This process
is repeated until the last file is read in or the maximum number of keyframes is reached.

BVA Import Options

Sample Every n Frame(s)

Imported motion data will be sampled every n frames. The function curve generated is
smoothed using all the imported data, but control points are spaced out giving the animator
some room to manipulate the imported data.

20
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DXF Import Options

Exchange Y and Z

Some modeling systems use a coordinate system that differs from the one used by
PiXELS:3D. This option is used to correct for that.

Smooth Normals

If checked, PiXELS:3D will automatically smooth all normals for shared vertices.

Scale

Sets the scaling factor for the imported model. (i.e. 0.5 = 50%)

Smooth Limit

Defines the breaking point (in degrees) for smoothed polygons. If the angle between
adjacent polygons is greater than this value, their normals will not be shared. If the angle is
less than or equal to this value, the normals will be averaged and shared.
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OBJ Import Options

Exchange Y and Z

Some modeling systems use a coordinate system that differs from the one used by
PiXELS:3D. This option is used to correct for that.

Use Existing Normals

If present, use the normals defined within the file, otherwise recompute them.

Scale

Sets the scaling factor for the imported model. (i.e. 0.5 = 50%)

Smooth Limit

Defines the breaking point (in degrees) for smoothed polygons. If the angle between
adjacent polygons is greater than this value, their normals will not be shared. If the angle is
less than or equal to this value, the normals will be averaged and shared.

3DMF Import

PiXELS:3D now has the ability to import 3DMF files.  3DMF is Apple's file format for
QuickDraw 3D.  The importer can read in Tri-Mesh, Tri-Grid, NURB, and three or four sided
polygons.  If the file contains polygons with more than four sides, you will be given a
warning indicating that some of the polygons are not being imported.
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File: Export
Saves a PiXELS:3D document in DXF, RIB, Multi-Frame RIB, 3DGF or 3DMF formats for use
with other software applications. Optionally exports a PICT map of the surface to aid in the
creation of texture maps.

1. Open or create a PiXELS:3D file. 
2. Choose Export from the File menu and drag the mouse to select and highlight

the desired format. 
3. In the dialog box, type in a name for the file to be exported.
4. Click Save, or click Cancel to return to the model without creating an export file. 
5. Choose export options for DXF and 3DGF formats.

DXF Export Options

Subdivide

Breaks the object down into finer polygons before exporting. The resolution is set in the
Object Info palette, using the U Step and V Step edit fields. (See Window Menu > Object
Info > UStep or Window Menu > Object Info > VStep for more info on this.)

Scale

Sets the scaling factor for the exported model. (i.e. 0.5 = 50%)

Tag Map Export

1. Using the tag tool, select key points on a model’s surface. (i.e. eye sockets)
2. Select File > Export > Tag Map. This creates a PICT file representing the

surface of the model, with tagged points marked as red squares.
3. Import the PICT into your favorite paint package. Use the tagged points as a

reference for painting. (i.e. Paint eyes where the eye sockets are.)
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3DGF Export Options

Splines

Retains spline information when exporting. Splines not supported by 3DGF are converted to
the closest supported spline.

Polygons

Converts splines to a linear basis when exporting. Some applications do not directly support
splines, so this option can be used along with the Subdivide option to smooth models.

Subdivide

Breaks the object down into finer polygons before exporting. The resolution is set in the
Object Info palette, using the U Step and V Step edit fields. (See Window Menu > Object
Info > UStep or Window Menu > Object Info > VStep for more info on this)

Scale

Sets the scaling factor for the exported model. (i.e. 0.5 = 50%)

3DMF Export Options

NURBS

Objects with a spline basis will be converted to NURBS (Non Uniform Rational B-Splines)
on export.

Polygons

All objects will be converted to polygons on export.

Subdivide

Spline based objects are smoothed before being converted to polygons for export.

Scale

Controls the relative size of the exported scene.
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File: Save [ S]
Saves changes made to the open model to a disk file. If no file has been created for the
model, Save behaves just like Save As.

1. Choose Save from the File menu or type S.
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File: Save As

Saves a new PiXELS:3D file or saves an existing one under a new name without overwriting
the original version.

1. Choose Save As from the File menu. 
2. A dialog box appears showing the default file name: Untitled Model. Type in a

new file name. 
3. Choose the folder and disk on which you want the document saved. 
4. Click Save, or click Cancel to abort.
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File: Revert To Saved
Discard any changes you have made to your model since the last time it was saved.

1. Choose Revert To Saved from the File menu.
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File: Render Setup [ U]
Sets the various rendering options.

1. Choose Render Setup from the File menu or type U.
2. Set the Render Setup parameters as desired.
3. Click the OK button to accept or the Cancel button to abort.

Render Setup Options

Let’s look at each of the options that can be set for the Render Setup Options dialogue
box.

28

PiXELS:3D v e r s i o n  3 . x

f
i
l
e

m
e
n
u
s



Renderer

Use this pop-up menu to select the rendering method you wish to use. PiXELS:3D has four
rendering methods to choose from:

Wireframe: The simplest and fastest rendering technique, it shows only the transparent
outline of forms.

Flat Shade: Gives the surface a faceted appearance to approximate the shape. Fast, but low
quality renderings—good for previews.

Gouraud Shade: Renders a smooth, diffuse object by interpolating shading values between
vertices. Not as fast, but higher quality to help see the details.

Phong Shade: Renders a smooth, specular object by interpolating normals between vertices.
The highest quality renderings, takes longer but worth it! Use for final rendering to achieve
broadcast quality images.

Image Size

A pop-up menu which lists common image formats. You can select one of the
predetermined image sizes or select the Custom menu item to manually enter any size.

Pixel Aspect Ratio

Some devices use non-square pixels (such as NTSC television). This option ensures
compatibility of images with these devices. The ratio is automatically determined for you
based on the image size that you selected.
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Scale

A scaling factor to apply to the image when rendering. (i.e. 400x400 with a scale of 0.5 will
render at 200x200)

Image Name

The name to be applied to the final rendering when saved.

Current Frame

Renders the current frame only (still image).

Range of Frames

Renders a range of frames (animation). The frame range is set using the two edit fields
immediately below this button. The first edit field is the start frame # and the second edit
field is the end frame #.

Step

Forces the renderer to render every nth frame.

fps

Sets the number of frames needed to create one second of finished animation. (frames per
second)

Background, Ambience & Fog Colors

Uses the Apple color picker to define a background, ambience or fog color. The background
color is merely placed behind rendered images. The ambient color is a ‘global’ illumination
present in all rendered scenes. The fog color is used when calculating fog in a scene.

Fog

Enables the fog option for the Flat, Gouraud and Phong renderers.

Inner Radius

Sets a radius around the Camera inside which fog has no effect.

Outer Radius

Sets a radius around the Camera outside which fog has a maximum effect. All points
between the inner radius and outer radius will be effected by fog based on their distance
from the viewer.

Motion Blur

Enables the motion blur option for the internal renderer. Motion blur is caused by the
exposure of a moving object over time.

Shutter Speed

Defines a percentage of time between frames during which the aperture is open. A higher
value causes greater motion blur. A value greater than one (1) can have unpredictable results
and should not be used.
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Samples

Defines the number of samples used over time to render one pixel. Higher sampling rates
will result in smoother motion blur, but will require longer rendering times.

Fields

Used to reduce temporal  aliasing when rendering for video. Note: if this option is enabled,
the Pixel Filter option should be set to none.

Depth of Field

Enables the depth of field option for the internal renderer. Depth of field causes objects over
a certain range of depth to appear in focus, while objects outside that range appear blurred.

fStop

Defines the size of the aperture opening on the Camera. A higher value results in a less
pronounced depth of field, while values closer to zero produce a more exaggerated depth of
field. Common values range from 1.2 to 22.

Anti-alias Sample Rate

Sets the number of sub-pixel samples to average together when anti-aliasing. Higher values
result in better anti-aliasing but require more RAM and time to render.

Pixel Filter

Sets the shape of the subpixel filter applied to supersamples when summing the final pixel’s
color.

Jitter

Controls the size of jittered offset used on subpixel samples.

Ray Tracing

Ray tracing is a technique for creating realistic looking images by tracing rays of light as
they bounce around a scene.

Backface Culling

When selected, this feature accounts for all surfaces that can not be seen from the Camera’s
perspective and removes any related rendering calculations for them. This speeds up
rendering time.

Invisible Shadows

Enabling this feature allows shadows to be rendered from an object that is invisible,
providing that the shadow casting feature for that object was turned on in the Object Info
palette.

Patch Subdivision

Divides the patches of all models in a scene into smaller pieces to create more detailed,
smoother models. Each model’s sub-division is based on settings placed in the Object Info
palette.

Render 2 Sided

When selected, this feature allows the insides of models that are exposed to the Camera to
be rendered.  However, use with caution as this may cause aliasing.
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File: Quick Render [ R]
Uses the options defined in Render Setup to render an image into the Camera view.

1. Choose Quick Render from the File menu or type R.
2. To cancel a rendering in progress type a period.
3. When you are finished looking at the rendering, click your mouse anywhere to

return to PiXELS:3D.
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File: Final Render [ F]
Uses the options defined in Render Setup to render a final image, or series of images to disk.

1. Choose Final Render from the File menu or type F.
2. To cancel a rendering in progress type a period.
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File: Quit [ Q]
Exits PiXELS:3D, returning you to the Macintosh desktop.

1. Choose Quit from the File menu or type Q.
2. If any unsaved changes have been made to the open file, PiXELS:3D asks

whether to save the changes before closing the file.
3. Click Yes to save changes, No to ignore changes, or Cancel to return to the

current model without exiting PiXELS:3D.
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Edit: Undo [ Z]
Reverses the most recent movement or repositioning applied to a model.

1. Choose Undo from the Edit menu or type Z.
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Edit: Cut [ X]
Deletes the selected model and stores it on the Clipboard.

1. Select the object to cut.
2. Choose Cut from the Edit menu, or hit X.
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Edit: Copy [ C]
Copies currently selected model into the Clipboard without changing the original model.

1. Select the object to be copied.
2. Choose Copy from the Edit menu or type C. The item will be stored in the

Clipboard for later use.
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Edit: Paste [ V]
Places the model copied to the Clipboard into the scene.

1. Choose Paste from the Edit menu or type V.
2. The model will be pasted where it was when it was originally copied.
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Edit: Clear [delete]
Deletes a selected model from the scene, leaving remaining models unchanged. The clear
command cannot be undone.

1. Select the object you wish to clear.
2. Choose Clear from the Edit menu or hit the Delete key.
3. A dialog box alerts you that this operation is irreversible. Click OK to confirm and

delete, or click Cancel to abort.
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Edit: Hide Selected [ 3]
Hides the currently selected model.

1. Select the object you wish to hide.
2. Choose Hide Selected from the Edit menu or type 3.
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Edit: Hide Unselected [ 7]
Hides all models except the currently selected model.

1. Select the object you wish to retain.
2. Choose Hide Unselected from the Edit menu or type 7.
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Edit: Show All [ 4]
Restore hidden parts of the model to the screen.

1. Choose Show All from the Edit menu, or type 4.
2. Any hidden objects will be made visible.
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Edit: Show Selected [ 5]
Restore hidden parts of the model to the screen.

1. Choose Show All from the Edit menu, or type 5.
2. Any hidden objects will be made visible
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Edit: Duplicate [ D]
Makes a clone of the currently selected model. The duplicate is placed directly on top of its
twin.

1. Select the object you wish to duplicate.
2. Choose Duplicate from the Edit menu or type D. A copy of the object will be

pasted directly on top of the original.
3. The duplicate is the currently selected model, so you can now move, resize,

reshape, etc... this object.
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Edit: Duplicate Hierarchy
Makes a clone of the currently selected model and all its children. The duplicate is placed
directly on top of its twin.

1. Select the parent of the hierarchy you wish to duplicate.
2. Choose Duplicate Hierarchy from the Edit menu. A copy of the hierarchy will

be pasted directly on top of the original.
3. The duplicate is the currently selected model, so you can now move, resize,

reshape, etc... this object.
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Edit: Step and Repeat
Copies an object and pastes it according to the offset instructions. The object may be pasted
as many times as desired.

1. Select the object you want to affect.
2. Choose Step and Repeat from the Edit menu.

Step and Repeat Options:

Step

The number of duplicates desired.

X, Y, Z Offset

Offset factor for x, y or z-axis.

X, Y, Z Scale

Scale factor for x, y or z-axis.

X, Y, Z Rotation

Rotation factor for x, y or z-axis.

Create Hierarchy

Links each duplicate to the first item in the chain.

Chain

Links each duplicate to the previous item in the chain.

OK

Accept and apply settings.

Cancel

Exit dialog without applying settings.
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Edit: Expand Hierarchy [ E]
This command affects the appearance of objects in the Schematic view which can be selected
in any of the view panes. When a parent object (an object that has children in the hierarchy)
is collapsed, its children are not displayed in the Schematic view, but rather only the parent
object is shown with a double outline to indicate that it has hidden children. When a parent
object is selected, this command will expand a collapsed parent or collapse an expanded
parent.
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Edit: Register Options [ E]
When upgrading your software, this is the dialog 
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Window: Object Info [ I]
All objects, including lights and the Camera, have a number of different settings that can be
assigned to them. The Object Info Palette displays all of these settings along with other
relevant information about the currently selected model, light, or Camera. To view and edit
these settings: 

1. Select Object Info from the Window menu or press I.
2. The Object Info Palette will appear. Click on the Object pop-up menu at the top

to select either a model, light or Camera. 
3.  Depending on your selection, different settings will appear. Settings are typed,

toggled, or selected from pull down menus.
Let’s examine the different settings that are available for models, lights and the Camera.

Object Info Options for a selected model

Object

A pop-up menu which allows you to directly select a different object for editing. 

Color

Click this box to open the Apple color picker to select a color for this object’s wireframe. It is
useful on complex scenes, when you have multiple objects overlapping each other. By color
coding them, they become easier to spot. Bright colors are usually preferred over muted
tones. This color does not affect the color of the object when rendered.
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Name

The name of the model. Can be up to 32 characters.

Rotation X

The rotation factor for the x-axis (pitch).

Rotation Y

The rotation factor for the y-axis (yaw).

Rotation Z

The rotation factor for the z-axis (roll).

Scale X

The scaling factor for the x-axis (width).

Scale Y

The scaling factor for the y-axis (height).

Scale Z

The scaling factor for the z-axis (depth).

Position X

The translation (offset) factor for the x-axis (left and right).

Position Y

The translation (offset) factor for the y-axis (up and down).

Position Z

The translation (offset) factor for the z-axis (in and out).

U/V Steps

The number of subdivisions or steps this patch contains in each direction. These values
cannot be changed directly.

U/V Basis

The basis of the spline used to interpolate this surface when either rendering or subdividing.

Close U

Closes the model along its u-steps.

Close V

Closes the model along its v-steps.
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U/V Subdivisions

The number of intermediate points added to this object when rendering. For example, start
with an object with a resolution of 10u x 10v. If U and V Subdivisions were both set to 2, the
object would be subdivided to a resolution of 20u x 20v for rendering. If U and V
Subdivisions were both set to 4, the object would be subdivided to a resolution of 40u x 40v
for rendering.

Bias

Controls the “lean” of the Tau and Beta splines.

Tension

Controls the “rigidity” of the Cardinal, Tau, Tensed-B, and Beta splines.

Skew

Forces patches with spline deformations to retain parallelism between v steps.

Proxy

Sets the proxy feature for the selected object. (See Edit Menu > Proxy.)

Visible

Sets the visibility for the selected object. (See Edit Menu > Hide Selected.)

Locked

Objects with this set cannot be selected or altered and will appear dimmed in the modeling
views. Locked objects will render normally.

Shadows: Cast

Enables shadow casting for this object. At render time, only objects with this option enabled
can cast shadows.

Shadows: Receive

Enables shadow receiving for this object. At render time, only objects with this option
enabled can receive shadows.
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Object Info Options for a selected light

If the selected object is a light, the Light Info dialog is displayed when the Object Info
menu-item is chosen.

Light Info Options

Color

Click this box to open the Apple color picker to select a color and intensity for this light.

Icon 

Enables the visibility of the light icon in the modeling views. When disabled, the light will
not be incorporated into the rendered image.
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Light Type

A pop-up menu from which you select the type of light you want. The types are:

Null: A light source which has no illumination, but can still glow.

Point: An omnidirectional light. Light rays travel in all directions from the light.

Spot: A unidirectional light. Light rays travel in a cone from the position of the light toward
the spotlight interest.

Sun: A light source that is infinitely far from the objects in the scene. The position of the
light and interest are only used to define the direction the light is coming from.

Position

Defines the position of the light in 3D space.

Interest

Defines the position of the interest in 3D space. (i.e. the spot at which the light is pointing.)
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Glow

When enabled, this light source will be visible at render time.

Falloff

When enabled, the area of affect of the selected light source will be limited by the inner and
outer core values. When disabled, this light source will have an infinite area of affect.

Inner Core

Defines the area upon which the light will have full effect.

Outer Core

Defines the area upon which the light will have diminishing effect.

Rate

Sets the softness or fuzziness of the outer core.

Shadows

Enables shadow buffering for this light. Only objects with shadow casting enabled will be
incorporated into the shadow buffer and only objects with shadow receiving enabled will
render with shadows.
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Buf Size

Controls the horizontal and vertical dimensions of the rendered shadow buffer. The higher
this number, the finer the detail in the rendered shadows for this light. Higher values also
require more RAM, and longer render times.

Density

Defines the density of the shadow. Higher values create darker shadows.

Samples

The number of physical samples taken from the shadow buffer for each rendered pixel in
the final image. Higher numbers will yield more accurate shadows, but may take longer to
render.

Cone Angle

Sets and defines the angle at which light rays emanate from a spot light.

Delta Angle

Sets the angle of decreasing light around the light cone.

Softness

Blurs the edges of cast shadows. Higher values produce smoother shadows.
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Object Info Options for the Camera

If the selected object is the Camera, the Camera Info dialog is displayed when the Object
Info menu-item is chosen.

Camera Info Options

Color

Click this box to open the Apple color picker to select a color for the Camera’s wireframe.

Position

Defines the position of the Camera in 3D space.

Interest

Defines the position of the Interest in 3D space.

Roll

Sets the angle of lateral inclination for the Camera.

Field of View

Sets the angle of view.

Shutter Speed

Defines a percentage of time between frames during which the aperture is open. A higher
value causes greater motion blur. A value greater than one can have unpredictable results.
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fStop

Defines the size of the aperture opening on the Camera. A higher value results in a less
pronounced depth of field, while values closer to zero produce a more exaggerated depth of
field. Common values range from 1.2 to 22.

Fog

Enables the fog option for the Flat, Gouraud and Phong renderers.

Anti-alias Sample Rate

Sets the number of sub-pixel samples to average together when anti-aliasing. Higher values
result in better anti-aliasing but require more RAM and time to render.

Visible

Enables the visibility of the Camera icon in the modeling views. Does not effect the rendered
image.
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Window: Point info [ P]
Used to precisely position points and set their weights for use with inverse kinematics.

1. Select a point (or a row of points.)
2. Select Point Info from the Window menu.
3. Enter coordinate information and IK information for the point(s)
4. Use the arrow buttons to edit neighboring points.
5. Click OK to accept settings or Cancel to abort.

Point Info Options

Object

A pop-up menu which allows you to directly select a different object for editing.

Position

Displays the x, y, and z positions in global coordinates.

<<<     >>>

Use these to select different points for editing.

IK Link Model

The IK Chain this point is linked to.

IK Link Point

The joint on the IK Chain this point is linked to.

IK Weight

Sets how much rotational information this point will inherit from the segment of the IK
Chain it is linked to, versus the previous segment in the chain. (i.e. A value of 1 tells the
point to inherit all rotational information from the IK Segment it is linked to. A value less
than 1, and the point will inherit that percentage from the segment it is linked to and the
remaining rotational information will be inherited from the previous segment in the chain.)

58

PiXELS:3D v e r s i o n  3 . x

w
i
n
d
o
w

m
e
n
u
s



Window: Shader Manager [ W]

Shader Manager

Every object in a scene has a shader associated with it. The shader defines the look of the
object when rendered. The Shader Manager palette is where shaders are created and
assigned to objects in a scene. Multiple objects can share a single shader.

1. Select an object(s) whose shader you wish to create or modify.
2. Select Shader Manager from the Window menu.
3. To modify the object’s shader, click on the highlighted shader

(the one outlined in red).
4. To create a new shader, click on an empty tile. If no empty tiles are visible, click

on the >>> button until an empty tile is encountered.
5. To load an RMan shader, option + click on an empty tile.
6. To delete a shader,  + click on the shader’s tile.
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Window: Flex [ B]
Sets the surface flexibility of the selected object.

1. Select a model
2. Choose Flex from the Window menu, or press B. 
3. Use the sliders to set new values.
4. Select either linear or smooth interpolation.

Flex Options

U

Sets the area of effect for the u axis.

V

Sets the area of effect for the v axis.

A linear interpolation will be used to remap surrounding points.

A smooth interpolation

A smooth interpolation weighted at the source.

A smooth interpolation weighted at the edges.
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Window: Link Options [ L]
Sets which attributes to inherit from the parent object and provides access to true Boolean
modeling.

1. Select a model.
2. Choose Link Options from the Window menu or press 

L.
3. Select which attributes to inherit.
4. Click OK to apply link settings or Cancel to abort.

Link Options Options

Scale

Inherit scaling factors from parent.

Rotation

Inherit rotational factors from parent.

Position

Inherit x, y, and z offset from parent.

Texture

Inherit all shader parameters from parent.

Lattice

Inherit lattice deformations from parent. (If the parent is linked to a lattice).

Boolean

Sets whether or not this object will affect its parent at rendering time.

Union

Renders the parent and child objects as though they were one. 

Intersection

Renders only the overlapping portions of the parent and child.

Difference

Carves out or subtracts the child from the parent when rendering. 61
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Smooth Seams

Enables Fusion™, Pixels proprietary seam smoothing technology, hiding the visible ridges
created when non-continuous surfaces intersect.

Range

Sets the size of the Fusion™ blending.

Intersections

Intersecting objects are smoothed. When this is active, the Range parameter is assumed to be
in world space.

Edges

The edges of the smoothed objects are blended into the parent object. When this is active,
the Range parameter is assumed to be in st (parameter) space.
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Window: MorphMaker [ M]
MorphMaker is a tool that allows you to define a neutral reference pose for an object and
any number of variations on that reference. These variations are called gestures. Any number
of gestures can then be blended in any amount to form a pose. This feature can greatly
simplify facial animation, among other things. 

1. Select a model.
2. Choose MorphMaker from the Window menu or type M.

MorphMaker Options

Gesture Pop-up Menu

Allows you to select a gesture to edit with the Gesture Slider.

Gesture Slider

Controls how much of the Gesture shown in the Gesture pop-up is added to the current
pose.

Set Reference

Saves the current shape of the selected object as the reference pose.

Keyframe Pose

Saves the current pose in a new keyframe at the current frame number.

Save Gesture...

Opens a dialog allowing you to name a gesture and then saves the current shape of the
selected object under that name.

Zero Gestures

Sets the effect of each saved gesture to zero, effectively returning you to the reference pose.
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Window: Timeline [ T]
Opens a floating window containing a graphical representation of animation timings for all
objects in a scene. All animatable parameters of an object can be directly edited from within
this window.

1. Select an object.
2. Click Animate in the main tool palette.
3. Click Timeline in the lower tool palette.

The Timeline window is divided into three main parts. From left to right they are the: object
pane, options pane and graph pane. There is also a group of push-buttons in the upper left
corner. The first button sets the graph pane to Bar mode. The second button changes it to
Curve mode. The second pair of buttons can be used to constrain movement of function
curve control points. The left button, if depressed, allows horizontal movement, i.e. you can
change the time of a control point. The right button, if depressed, allows vertical movement,
i.e. you can change the value of the parameter at that time. You can pan by shift-dragging
in any pane. You can zoom by option-dragging in any pane. The window can be resized
by dragging its bottom-right corner.
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Object Pane

You can select an object by clicking on its name in the object pane. The entry for the selected
object will appear indented. The object pane is hierarchical, like an outline. You can click the
group expander to the left of an object name to show or hide the parameter groups for that
object. If the object has any objects linked to it (children) they will show up here as well.
Clicking the group expander for a parameter group will reveal the animatable parameters
for that group. Parameters can be expanded in this way as well. Expanded parameters
reveal a color box and a value number. The color box shows the color that parameter’s
function curve will have in the graph pane. To change the color, click on the color box to
open the Apple color picker dialog. The value number displays the value that that
parameter has at the current frame. This value can be changed by clicking on the value
number and typing in a new number. Type the return or enter key to apply the new
value. To create a new keyframe, option-click any object group, parameter group or
parameter. A black keyframe marker will appear in the graph pane.

Options Pane

There are nine options available in the options pane: Wireframe color, Visible, Proxy, Lock,
Skew, Close u, Close v, Cast shadows, and Receive shadows. If you click and hold on an
option selector for a few seconds, a description of what it does appears in the pane header.
See Window > Object Info for a description these options. Not all objects have all nine
options available. Lights and the Camera, for example, have wireframe color and visible
options, but none of the others.

Graph Pane

The current frame can be changed by dragging the key insertion point. If you hold down the
option key while you drag, the key insertion point will change, but the current frame will
not. This can be used to copy keyframes from one point in time to another.

The appearance and behavior of the graph pane will differ depending on whether Bar mode
or Curve mode is selected. Bar mode shows the function curve for each fully expanded
parameter in its own function curve pane. The function curve pane can be resized by
dragging the bar just below the pane. To select bar mode, click on the Bar button (the left
button in the upper left corner of the window). Curve mode allows you to view and edit
multiple curves simultaneously. Any curve which has been fully expanded in the hierarchy
will show up in this mode, so you can even edit curves from multiple objects. To select
curve mode, click on the Curve button (the second one from the left in the upper left corner
of the window).

Keyframes appear in the bar graph display as black rectangles. If the horizontal movement
button is depressed, you can move a keyframe to a different time by dragging it. Multiple
keyframes can be selected at one time. To select multiple keyframes, -click and drag a box
around the keyframes you want selected. -shift click toggles selected keyframes. Selected
keyframes can be moved or they can be deleted by typing the delete key. NOTE: the cursor
must be inside the Timeline palette when typing.

Function curves are bézier curves. There is one control point for each key frame. -click on
a control point to select it. The selected point will show a control handle that can be adjusted
to alter velocity from keyframe to keyframe. By default, control handles will maintain
continuity from one side of the control point to the other. If you want to break continuity (to
have a sudden change of direction or velocity) at a control point, control-click and drag
the handle. The continuity will remain broken until you control-click on the handle a
second time.
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Navigational Controls

In Point

Returns the key insertion point to the In Point as defined in the Render Setup dialog.

Previous Key

The key insertion point is placed on the first keyframe occurring directly before the current
key insertion point. Only keyframes belonging to the currently selected object are
considered.

Previous Frame

Moves the key insertion point back one frame.

Next Frame

Move the key insertion point ahead one frame.

Next Key

The key insertion point is placed on the first keyframe occurring directly after the current
key insertion point. Only keyframes belonging to the currently selected object are
considered.

Out Point

Moves the key insertion point to the Out Point as defined in the Render Setup dialog.
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Window: Script Editor [ Y]
A simple text interface which facilitates the creation and editing of object scripts or
expressions. The currently selected object’s script is visible in this window. If more than one
object is selected, the most recently selected object (the one highlighted in green) will be
used.

1. Select an object.
2. Choose Script Editor from the Window menu, or type Y.
3. Type a script or expression into the edit field.
4. Click Run to execute the script. The script is also executed whenever the current

frame changes or the source object is modified in any way.
5. Click Load to read a script from a file.
6. Click Save to save the current script to a file.

Script Editor Options

Save

Saves the current script to disk.

Load

Loads a pre-defined script from disk.

Run

Executes the current script.
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Window: History [ H]
Provides a visual reference of the command sequence used to create the current scene.
Command sequences can be copied and pasted into stand-alone scripts to create macros (see
the Scripts tool). Commands can also be entered manually.

1. Choose History from the Window menu, or type H.
2. To enter a command manually, click inside the edit field at the bottom of the

palette. To exit manual entry mode, type return.
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Window: Layers [ J]
Creates and administrates object groups.

1. Choose Layer Manager from the Window menu, or type J.
2. To create a new layer, click on the New button.
3. To delete a layer, select the layer and click on the Delete button.
4. To add objects to a layer, select the object(s) you want to add, select the layer

you want to add them to and click on the Add button.
5. To remove objects from a layer, select the object(s) you want to remove, select

the layer you want to remove them from and click on the Remove button.
6. To toggle visibility of a layer, click in the V column to the left of that layer’s name.
7. To toggle the locked status of a layer, click in the L column to the left of that

layer’s name.
8. To toggle the Fusion™ status of a layer, click in the F column to the left of that

layer’s name. (See Fusion™ under the Link Options dialog)
9. To select a layer, click on the layer’s name.
10. To edit a layer’s name, click on the name a second time. Type return to apply

the new name.
11. To select all objects on a layer, + click on that layer. Note: anything selected

prior will now be unselected, unless it is part of the selected layer.
12. To toggle the selection of all objects on a layer, + shift + click on that layer.

Note: anything selected prior will remain selected.
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Window: Pixel Notes [ K]
Facilitates the communication among artists collaborating on a project. Can also be used to
help track revisions and client changes.

1. Choose PixelNotes™ from the Window menu, or type K.

PixelNotes™ Options

Display on open

The selected note will be displayed whenever the current project is opened.

New

Creates a new note.

Delete

Deletes the currently selected note.

OK

Accepts changes end exits the dialog.
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Window: Full Screen [ =]
Sets the viewing window to either fill the screen (default) or fit into a resizeable, relocatable
window.

1. Choose Full Screen from the Window menu, or type F.
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Window: Snap To Grid [ G]
Provides for more precise positioning by aligning changes to an underlying grid. The grid
size can be changed from the command line using the gridsize command.

1. Choose Snap To Grid from the Window menu or type G.
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Window: View Options [ /]
Dialog which controls many view specific parameters.

1. Select View from the Window menu or type /.

View

When clicked on, this pop-up menu lists optional views that the selected viewing pane can
display. Any view except the Camera view can be changed. You can select from the
following view options: 

Top View
Front View
Right View
Schematic View—discussed at the end of this chapter
ShaderMaker View—discussed at the end of this chapter
Twist & Taper View—discussed at the end of this chapter
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Shaded Preview

Shaded preview displays an object preview, complete with textures, and transparency.

Depth Cue

The Depth Cue option draws wireframes which fade to the Background as the distance from
the Camera approaches the Outer Radius.

Inner Radius

Distance from the Camera where wireframes begin to fade.

Outer Radius

Distance from the Camera where wireframes are 100% Background.

Background

Every view has a background color. Clicking in the box to the right of the Background title
will open the Apple color picker, allowing you to set the background color.

Image

Any view can also have a PICT image as a background. This is helpful when modeling
something from a scanned image (i.e. take photos of an object from the top, front and right)
or for placing a computer model into a real scene. PICT sequences can also be used for
rotoscoping. Click on the box to the right of the Image check box to open the Texture
Manager dialog. See the ShaderMaker section for more details.

Visible Grid

When checked, this option shows this viewing panes grid. When unchecked, the grid will be
hidden.
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Grid Size

Sets the size of the visible grid in PiXELS:3D units. The Visible Grid option must be
checked before the grid can be seen.

Grid Color

Clicking on this box opens the Apple color picker, allowing you to set the color of the grid
lines.

Grid Major

Clicking on this box opens the Apple color picker, allowing you to set the color of the center
or origin grid lines (the ones which intersect at 0,0).

Visible Axis

When checked, this option shows the axis reference icon in the lower left corner of this
viewing pane. When unchecked, the axis reference icon will be hidden.

Clipping

When checked, portions of objects which are closer than Near Plane or farther than Far
Plane are invisible or clipped. This makes working with complex scenes much easier,
allowing you to focus on a single object or even a portion of that object.

Absolute/Relative

When the Absolute option is selected, the clipping planes are considered to be absolute
(world space) coordinates.
When the Relative option is selected, the clipping planes are considered relative to the
Camera, so as you dolly in and out, different portions of the scene appear and disappear.
These options are a Radio Group, which means selecting one will automatically deselect the
other. Both cannot be selected at one time.

Near Plane

When Relative is selected, this value defines how close an object can be to the Camera
before being clipped.
When Absolute is selected, this value defines the minimum position where, along the
orthogonal (perpendicular) axis to this viewing plane, objects are visible.

Far Plane

When Relative is selected, this value defines how far an object can be from the Camera
before being clipped.
When Absolute is selected, this value defines the maximum position where, along the
orthogonal (perpendicular) axis to this viewing plane, objects are visible.

Show Links

Shows the Links between the 'parent' and 'child' objects

Show Path

Shows the Links between the object  andits path.

75

PiXELS:3D v e r s i o n  3 . x

w
i
n
d
o
w

m
e
n
u
s



Drawing Options

The Drawing Options palette has two collums. The 'Selected Objects' and 'Unselected
Objects'. Both have the same options available. 

These are:
Hull: Shows a wire mesh outline of objects. 
Surface: Draws the actual spline curves that make up a shape. This is the most accurate
representation of a shape, but will take more time to draw. 
CVs: Display's the Control Vertices. 
Center: Shows the objects center, and X , Y , and Z orientation. 
Normals: Shows the surface normals of the objects. 
Bounds: Shows the Bounding boxes of the object. 
Spline: Shows the central Bezeir curve of the objects.
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Select: Parent
Selects the parent (if there is one) of the currently selected object.
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Select: Interest
Selects the interest (if there is one) of the currently selected object.
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Select: Path
Selects the path (if there is one) of the currently selected object.
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Select: Lattice
Selects the lattice (if there is one) of the currently selected object.
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Select: Bone
Selects the IK chain (if there is one) of the currently selected point.
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Select: Skin
Selects the skin (if there is one) of the currently selected IK chain.

82

PiXELS:3D v e r s i o n  3 . x

s
e
l
e
c
t

m
e
n
u
s



Select: Next Object [ ] ] 
Selects the next object in the scene list. The order of objects in this list is determined by the
order in which objects are created.
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Select: Previous Object [ [ ]
Selects the previous object in the scene list. (see above)
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ShaderMaker
ShaderMaker allows you to describe the material properties of your object’s surface.
ShaderMaker gives you full control over every aspect of shading a surface, from the color of
the surface to complex light interactions such as reflection and refraction. All of this can be
controlled using any one of ShaderMaker’s nodes.

Nodes

Node is the name given to the basic building blocks used within ShaderMaker. To see all the nodes
available, choose Window > ShaderMaker and open the ShaderMaker dialog box then click
on the first Diffuse pop-up menu. Take a moment to read the names of all the nodes. Every
one of these nodes will produce a color, so we call these color nodes. Now click on the second
Diffuse pop-up menu. Every one of these nodes will produce a numerical value, so we call
these value nodes. Each node has a set of variables associated with it, called input variables.
These variables describe the characteristics of a given node. Input variables require either a
color or a value as input. Some common variables are scale, softness, grain and turbulence.

Node Interaction

Within ShaderMaker, nodes can be linked to other nodes, making it possible to control a
node’s input variable with the output of another node. This interaction between nodes may
at first seem complex, but it is, in fact, quite straight forward. It works somewhat like a
patch bay, plugging values or colors from one node into another. There is no theoretical limit
to how deep these interactions can go, however available memory and CPU speed will play
a role in setting practical limits.

Shaders

A shader is a combination of nodes which work together to create the final desired color,
pattern, texture or look for your 3D object. Every shader is made up of 14 inputs controlling
such variables as Diffuse Color and Reflectivity. Each of these inputs has a node associated
with it which defines its value or color. Shaders can be created from scratch or you can use
the Load button to read a Shader from disk. Once a Shader has been read into
ShaderMaker, it can be edited to create a new look.

ShaderMaker Options

After selecting the object you want to effect, open ShaderMaker by choosing the 
Window > ShaderMaker menu item.
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From this dialog box you have access to a suite of tools designed to help you interactively
create realistic looking textures without programming. 

Preview

Applies the current settings to a sphere and renders it into the Preview Image box.

Load

Load a shader from disk.

Save

Save the current shader to disk.

Render Method

Defines the rendering type used by this shader. The types available are:

Normal: Standard Phong illumination.

Toon: A high contrast renderer which resembles traditional cel animation.

Custom: Unimplemented.

Trans Method

The method used to sum overlapping, semi-opaque pixels.

QD3D preview size

Defines the size, in pixels, of the preview texture map.

Diffuse

Sets the surface illumination caused by scattering light.

Specular

Sets the intensity of the highlight reflection.88
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Roughness

Defines the spread of the specular decay over the object surface.

Opacity

Density or transparency of the material.

Ambient

Overall or internal illumination for a given object.

Environment

Defines what is to be reflected or refracted.

Reflectivity

How much of the environment is to be reflected.

Index of Refraction

Defines the distortion of light rays as they pass through transparent or partially transparent
objects.

Bump

Simulates bumps in a surface by perturbing the normals.

Displacement

Similar to bump, but rather than simulating, displacement actually alters the surface.

Apply To:

Sets the model group you want this shader applied to. The options are:

Object - Applies the current settings to the currently selected model.

Children - Applies the current settings to all the children of the currently selected model.

Group - Applies the current settings to all objects associated with the current object.

All - Applies the current settings to all the models in a scene.

OK

Apply settings to selected model group and return to PiXELS:3D.

More About Nodes

As discussed earlier, shaders are built of small components called nodes. There are two types
of nodes; those that return colors and those that return values. Because of the flexibility
inherent in ShaderMaker, the line between color nodes and value nodes is very grey. In fact
color nodes can be used as value nodes. ShaderMaker simply converts the intensity of the
color into a value and passes that to the parent node. Value nodes cannot directly return
color values, but they are used to define the components of a user color—so you could quite
easily create a shader that used a value node to create a color. A simple example would be a
shader that used a User Color node to define Diffuse Color. The rgb components could be
defined using the absolute value of the xyz components of the surface normal. Another
example would be to use a Function Curve node to define the hue component of a User Color
node. This allows you to change the hue of your color over time! 89
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Color Nodes
Color nodes are used to define a color attribute such as what gets reflected or what color the
surface of the object is. The base nodes which require color node inputs are: Diffuse,
Specular, Ambient and Environment.

White, Black, Red, Green, Blue & Yellow

Predefined colors. These nodes contain no user definable parameters.
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User Defined

Allows the user to define a color in either the rgb, hsv or hsl color space. Optionally allows
the user access to the Apple color picker.

Color Model

A pop up menu used to define the preferred color space. Options include rgb, hsv and hsl.

r/h Slider

Defines the function/scalar value used to determine the red component of the user color.
When in hsv or hsl mode, this changes to the h slider, which controls the hue component.

g/s Slider

Defines the function/scalar value used to determine the green component of the user color.
When in hsv or hsl mode, this changes to the s slider, which controls the saturation
component.

b/l/v Slider

Defines the function/scalar value used to determine the blue component of the user color.
When in hsv mode, this changes to the v slider, which controls the value component. When
in hsl mode, this changes to the l slider, which controls the lightness component.
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Image Map

Uses a PICT image or series of images to define surface color.

Image

The currently loaded PICT image. Click on the preview image to load a different image.
PICT images can be stored in one of three places; inside the global Textures folder, inside the
current project folder or inside the current project’s Textures folder.

Super Sample

Enables the super sampling option. Super sampling smooths out the pixelization and
aliasing that can occur when viewing textures from a distance or up close.

Max Rate

Defines the maximum number of samples to use when super sampling. Higher values give
smoother results but can take longer to render.
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Mapping Mode

A pop up menu used to define the mapping method to use.

uv, vu – These two options behave like magic rubber wallpaper that can be stretched over
the object surface – the pixels:3d of the PICT file are made to correspond with set positions
on the object’s surface. As a result, any distortion from stretching appears more natural. This
is by far the most versatile mapping method. The two options are the same except that the
image map is rotated 90 degrees.

xy, xz, yz – Works like a slide projector. The “screen” being projected onto is equal to one of
the three viewing planes; xy, xz or yz. The size and position of the ‘screen’ is defined using
the U Scale, V Scale, U Offset and V Offset parameters. Any surface not oriented with the
selected viewing plane will distort the texture when rendering.

Global Coordinates

Forces projected mappings to use global coordinates rather than local coordinates.

Mirror U/V

When tiling texture maps, these options can help hide the seams between texture cells.

U/V Scale

Sets the scale factor to apply to the texture map when using UV or VU mapping. When
using one of the projection map methods, use these to define the size (in world space) of the
texture map you are projecting on to the surface.

U/V Offset

Defines the position of the first texture tile un UV space. When using one of the projection
map methods, defines the position of the upper left corner of the projection ‘screen’ in
PiXELS:3D units.
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Blender

Merges two color nodes using a value node as an alpha mask.

Input 1

Color node defining source channel 1.

Slider

Sets the weight assignments between channel 1 and channel 2. A value of 0.0 will reveal
100% channel 1, 0.5 will show a 50/50 blend of channels 1 and 2, 1.0 will show 100%
channel 2.

Input 2

Color node defining source channel 2.

Blending Function

Value node used to define the blending mask. NOTE: the blending mask DOES NOT
override the slider. If you want the blending function to fully control the output image, set
the slider to 1.0.
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Wood

A 3D texture which simulates wood patterns.

Light Wood

Color node used to define the base wood color.

Dark Wood

Color node used to define the color of the concentric rings running through the texture.

Scale

Slider/Value node used to define the size of the wood grain.

Turbulence

Slider/Value node used to define the randomness of the wood grain.

Global Coordinates

When this item is checked, the texture is computed in world space rather than object space.
If the object is moving in any way and this option is on, the texture will appear to ‘slide’
through the object when rendered.
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Brick

A 2D texture which simulates brick or stone wall patterns.

Brick Color

Color node used to define the stone segments.

Mortar Color

Color node used to define the area between stone segments.

Brick Width

Slider/Value node used to define the horizontal scale of the bricks.

Brick Height

Slider/Value node used to define the vertical scale of the bricks.

Mortar Thickness

Slider/Value node used to define the spacing between bricks.

Turbulence

Slider/Value node used to define the low frequency randomness of the brick pattern.

Softness

Slider/Value node used to define the how softly brick blends into mortar.

Noise

Slider/Value node used to define the high frequency randomness of the brick pattern.

96

PiXELS:3D v e r s i o n  3 . x

s
h
a
d
e
r
m
a
k
e
r



Spots

A 3D texture constructed of random spots.

Base Color

Color node defining the area behind the spots.

Spot Color

Color node defining spots.

Spot Size

Slider/value node defining the size of the spots.

Softness

Slider/value node defining the transition from spot to base colors.

Threshold

Slider/value node defining the lean towards base or spot color. Values close to zero will
favor the base color, while values closer to 1 will favor the spot color.

Global Coordinates

When this item is checked, the texture is computed in world space rather than object space.
If the object is moving in any way and this option is on, the texture will appear to ‘slide’
through the object when rendered.
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Tile

A 2D texture which simulates tile patterns.

Tile 1

Color node used to define the even tiles. The bottom menu is used to define the tile shape;
either rectangular or elliptical.

Tile 2

Color node used to define the odd tiles. The bottom menu is used to define the tile shape;
either rectangular or elliptical.

Mortar Color

Color node used to define the area between tiles.

Tile Width

Slider/Value node used to define the horizontal scale of the tiles.

Tile Height

Slider/Value node used to define the vertical scale of the tiles.

Mortar Thickness

Slider/Value node used to define the spacing between tiles.

Turbulence

Slider/Value node used to define the low frequency randomness of the tile pattern.

Softness

Slider/Value node used to define how softly the tile blends into mortar.

Noise

Slider/Value node used to define the high frequency randomness of the tile pattern.

98

PiXELS:3D v e r s i o n  3 . x

s
h
a
d
e
r
m
a
k
e
r



Clouds

A 3D fractal texture which simulates cloud patterns.

Light Cloud

Color node defining the clouds.

Dark Cloud

Color node defining the area behind the clouds.

Scale

Slider/value node defining the size of the clouds.

Iterations

Slider/value node defining the complexity of the cloud patterns.

Global Coordinates

When this item is checked, the texture is computed in world space rather than object space.
If the object is moving in any way and this option is on, the texture will appear to ‘slide’
through the object when rendered.
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Marble

A 3D texture which simulates marble or stone patterns.

Base Color

Color node defining the main portion of the texture.

Veins

Color node defining the marble veins running through the texture.

Scale

Slider/value node defining the size of the veins.

Turbulence

Slider/Value node used to define the low frequency randomness of the marble veins.

Global Coordinates

When this item is checked, the texture is computed in world space rather than object space.
If the object is moving in any way and this option is on, the texture will appear to ‘slide’
through the object when rendered.
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Granite

A 3D texture which simulates speckled granite patterns.

Base Color

Color node defining the main portion of the texture.

Spot Color

Color node defining the speckles.

Scale

Slider/value node defining the size of the speckles.

Shades

Slider/Value node used to define the number of varying shades visible inside the texture.

Balance

Slider/value node defining the lean towards base or spot color. Values close to zero will
favor the base color, while values closer to 1 will favor the spot color.

Global Coordinates

When this item is checked, the texture is computed in world space rather than object space.
If the object is moving in any way and this option is on, the texture will appear to ‘slide’
through the object when rendered.
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Math Function

A utility node. Can be used to mathematically merge values, nodes and other parameters.

Function

Pop up menu listing available math functions.
The available functions are:

Add - returns Value 1 plusValue 2.
Subtract - returns Value 1 minusValue 2.
Multiply - returns Value 1 times Value 2.
Divide - returns Value 1 divided by Value 2.
Sin - returns the sin of Value 1. Value 2 is ignored.
Cos - returns the cosin of Value 1. Value 2 is ignored.
Tan - returns the tangent of Value 1. Value 2 is ignored.
Sqrt - returns the square root of Value 1. Value 2 is ignored.
Pow - returns Value 1 to the Value 2 power.
Log - returns Value 1 log Value 2.
Mod - returns the modulus (remainder) of Value 1 divided by Value 2.
Abs - returns the absolute value of Value 1. Value 2 is ignored.
Sign - returns -1 if Value 1 is less than 0, returns 1 if Value 1 is greater than 0 and

returns 0 if Value 1 is equal to 0.  Value 2 is ignored.
Min - returns Value 1 if Value 1 is less than Value 2, otherwise Value 2 is returned.
Max - returns Value 1 if Value 1 is greater than Value 2, otherwise Value 2 is

returned.
Clamp - returns Value 1 unless Value 1 is less than 0 or greater than 1. If Value 1 is

less than 0, 0 is returned. If Value 1 is greater than 1, 1 is returned. Value 2 is
ignored.

Ceil - returns Value 1 rounded up to the next whole number. Value 2 is ignored.
Floor - returns Value 1 rounded down to the last whole number. Value 2 is ignored.
Round - returns Value 1 rounded to the closest whole number. Value 2 is ignored.
Step - returns 0 if Value 1 is less than Value 2 . Returns 1 If Value 1  is greater or

equal toValue 2.
Smoothstep - returns Value 1 bicubically smoothed. Value 2 is ignored.

Value 1

Slider/value node defining the first value in the math equation. 

Value 2

Slider/value node defining the second value in the math equation.102
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Edge Blend

Blends color nodes based on surface and Camera angles.

Inner Color

Color node defining surfaces facing toward the Camera. 

Outer Color

Color node defining surfaces facing away from the Camera. 

Attenuation

Slider/value node defining the power curve used for transition from inner to outer colors.
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Mesher

A color node used to apply mesh warps to other color nodes.

Input

Color node defining base image used. This is what will appear in the preview window.

Mesh

Pop up menu used to select the resolution of the underlying mesh.

Grid

When enabled, the underlying mesh is visible.

Stretch

Pushes and pulls the mesh around.

Twist

Rotates the mesh.

Bulge

Scales the mesh up.

Pinch

Scales the mesh down.

Melt

Randomly perturbs the mesh.

Inner Core

Defines the portion of the mesh effected 100% by the current tool.

Outer Core

Defines the total area of the mesh effected by the current tool. The area lying between the
inner and outer core is the area of diminishing effect.
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Cuber
A color node used to apply cubic environment maps. 

Top, Right, Front Left, Back, Bottom: The color nodes used to define the environment as
seen from these angles.

Blend
Unimplemented.

Custom
Unimplemented.
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Value Nodes
Value nodes define a value attribute such as bump height or reflectivity. Value nodes are
almost always used in conjunction with a slider. The value returned by the node is
multiplied by the slider value.

Slider

Simply return the value of the slider.

Frame Number

Returns the current frame number.

Object Velocity

Returns the speed, in PiXELS:3D units, at which the current object is moving.

s/t - Texture Coordinate

Returns the location, in st space, of the current pixel being rendered.

X/Y/Z - Current Point

Returns the location, in world space, of the current pixel being rendered.

X/Y/Z - Surface Angle

Returns the surface normal of the current pixel being rendered.
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Image Map, Blender, Wood, Brick, Spots, Tile, Clouds, Marble, Granite,
Math Function & Edge Blend

See the Color Nodes section for more information

Function Curve

Graphs values relative to time. Function curve points can be added, removed and edited
from the Timeline palette, allowing for almost infinite control of values over time. To edit a
function curve, exit ShaderMaker and open the Timeline palette. Expand the current
object. Locate the Shader function curve group. Expand this item and you will find your
newly created function curve.

X/Y/Z - Current Point (Local)

Returns the location, in local space, of the current pixel being rendered.
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fBm

A multi-fractal function. Very robust.

Signed

When checked, values returned will be in the range of -1 to 1. If unchecked, values less than
0 will be returned unsigned. i.e. a value of -.25 will be returned as .25.

Fractal Increment

Lower values will result in a smoother noise gradient.

Frequency Gap

Higher values will produce larger fractals.

Octaves

Defines the number of iterations for the fractal function. Higher values will produce more
detailed fractals.

x Index, y Index and z Index

Defines the position point from which to derive a noise sample.
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Turbulence

Another fractal function. Turbulence is always unsigned, returning values between 0 and 1.

x Index, y Index and z Index

Defines the position point from which to derive a noise sample.

Octaves

Defines the number of iterations for the fractal function. Higher values will produce more
detailed fractals.
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Fractal Sum

Another fractal function. Fractal Sum returns values between -1 and 1.

x Index, y Index and z Index

Defines the position point from which to derive a noise sample.

Octaves

Defines the number of iterations for the fractal function. Higher values will produce more
detailed fractals.

Custom

Unimplemented.
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Shading

At render time, patches are smoothed out and subdivided into triangles. How smooth a
patch becomes is controlled using the Object Info palette’s U & V Subdivision settings. The
higher these values, the smoother the patch will appear at render time and the more
memory it will require. Each triangle is a planar surface with its front oriented in one
direction. The renderer calculates the relation between this orientation and the light sources
in order to determine the shading of each triangle.

Ambient, Diffuse, Specular Areas of Illumination

A surface rendered in PiXELS:3D combines three different types of illumination to simulate
the physical properties of light; ambient, diffuse and specular. Ambient shading represents
the global ‘scattered’ light present in most scenes. A scene within a brightly lit white room
would have high ambience. A scene in outer space would have no ambience. A shader with
no diffuse or specular, but 100% ambient can be used on objects which require no shading,
like backgrounds or glowing objects. Diffuse shading is the base illumination of any object,
showing the subtle fluctuations in a surface through variations in highlight and shadow.
Specular shading simulates the effect of light rays bouncing from the object to the observer’s
eyes, creating a highlight or hot spot. The size of this highlight can be controlled through the
Roughness parameter to simulate a wide variety of materials, from plastic to metal.

Defining Colors

There are many options for defining colors. The most common is to use the User Color node.
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Defining Values

Most values are defined using a combination of input node and slider value. The value
returned by the node is multiplied by the slider value before being used. The Slider node
always returns a value of 1.0, so the value set using the slider control is the value that will
get passed into the renderer. If a color node is selected, its rgb value will be converted to hsv
and the v component will be used.

2D vs. 3D Textures

There are two types of textures in ShaderMaker; 2D and 3D. The difference between them is
the coordinate system upon which they are based. A 2D texture exists in a 2D world - with
only 2 coordinates available. For each pair of coordinates there is a corresponding color. The
simplest example is a PICT image. Given an xy pair we could easily find the corresponding
pixel and its rgb color. 3D textures are a bit more complicated. These textures are like blocks
of a material with the object enclosed. Each point within the block can have a different color.

Animating Textures

Any value parameter can be animated. From the pop up menu, select Function Curve. Using
a Function Curve you can graph values relative to time. Another way to animate textures is
to use an animated PICT sequence. To do this, you will need a series of sequentially
numbered PICT files, with a five digit numeric extension like this: ‘texturename.00000’. At
render time, the Texture Manager will automatically load the file whose numeric extension
matches the current frame number. If the current frame is greater than the last image, the
system will cycle the frames, starting with the first frame again. If a frame is missing from
the animated PICT sequence, a blank image will be used in its place.
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Bump Mapping

Bump mapping, also known as normal perturbation, creates the illusion of surface
roughness by altering the surface normals without actually modifying the surface itself. This
illusion works well when viewed from the front, but when viewed from the side, it becomes
obvious that the surface is actually flat. Height or depth of the bumps can be controlled
using the Bump slider.

Displacement Mapping

Displacement mapping takes bump mapping to the next level, altering the actual surface
itself. Because of this, higher levels of subdivision are required. To change the subdivision
level for an object with displacement, select the object and use the Object Info palette to
change the U/V Subdivision parameters to a higher value like 8 or 12. The actual levels
required will depend on the resolution of the rendered image, the object’s proximity to the
Camera and the detail inherent in the displacement map.

Environment Mapping

Environment mapping can be used to simulate the effect of an image reflected onto the
object’s material—without using raytracing. Any color node can be used as an environment
map, but it should be noted that all nodes used in this manner will be given a spherical
parameterization as if it were a colored sphere that surrounds the object and reflects from
the object’s surface. Unlike other types of maps, a reflection map is not linked to the object,
and will remain stationery when the object moves or rotates. The amount of environment
reflected in an abject is controlled using the Reflectivity control.
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Shadows

Any renderable object can receive and/or cast shadows. You can set these options using the
Object Info palette. 
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View > Pan [shift]
Moves the center of the current viewport. This tool does not effect the geometry of a model. 

1. Click View from the main tool palette.
2. Click Pan in the lower tool palette.
3. Click in any window view and drag the mouse to move the center of that window.
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View > Zoom
Scales the current view larger in 200% increments or smaller in 50% increments.

To zoom in:
1. Click View in the main tool palette.
2. Click Zoom in the lower tool palette. 
3. Click in any window view. Each click doubles the size of the image. 

To zoom out:
1. Click View in the main tool palette.
2. Click Zoom in the lower tool palette. 
3. -click in any window view. Each click reduces the size of the image by half. 
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View > Orbit [control]
Rotates the Camera around the Interest.

1. Click View in the main tool palette. 
2. Click Orbit in the lower tool palette. 
3. Click in the Camera view and drag the mouse in any direction. The view turns as

the mouse moves around. 
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View > Dolly [option]
Interactively changes the user’s view of the current view port in or out of a scene.

1. Click View in the main tool palette. 
2. Click Dolly in the lower tool palette. 
3. In any view window, click and drag the mouse. To bring the model closer (dolly

in), move the mouse toward the bottom of the screen. To move the model further
away (dolly out), move the mouse toward the top of the screen.
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View > Time [control+shift]
Moves the scene forward or backward in time. Can be used to preview animations, or
navigate through an animation.

1. Click View in the main tool palette. 
2. Click Time in the lower tool palette. 
3. Click in any view and drag the mouse left to move backward or right to move

forward in time. The view and frame counter change as the mouse moves.
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Control > Move [q]
Sets how far the model is offset from the center of the grid.

1. Click Control in the main tool palette. 
2. Click Move in the lower tool palette.
3. Click and drag in any window to move the currently selected model.
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Control > Rotate [w]
Pivots the model, changing its orientation in 3 D space.

1. Click Control in the main tool palette. 
2. Click Rotate in the lower tool palette.
3. Click in any view and drag the mouse in any direction to rotate the currently

selected model.
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Control > Scale [e]
Resizes the currently selected object.

1. Click Control in the main tool palette. 
2. Click Scale in the lower tool palette.
3. Drag the mouse up or down in any window to rescale the selected object.

Moving the mouse up enlarges the object. Moving down reduces the selected
object. 
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Control > Expand [r]
Expands the currently selected object by ‘pushing’ each vertex out (or in) along its normal
vector.

1. Click Control in the main tool palette. 
2. Click Expand in the lower tool palette.
3. Drag the mouse up or down in any window to expand the selected object.

Moving the mouse up expands the object. Moving down contracts the selected
object.
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Control > Center [t]
Moves the x, y, z center of the selected object. Used most often to set an object’s pivot point.

1. Select the object.
2. Click Control in the main tool palette. 
3. Click Center in the lower tool palette.
4. Click and drag to move the center of the currently selected object. 
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Control > Align [y]
Aligns the current object’s center point with the center point of the next object selected.

1. Select the object(s) to be aligned.
2.  Shift + select the target object. This object should be highlighted in green. If it

isn't, deselect everything and go to step 1.
3. Click Control  in the main tool palette.
4. Click Align in the lower tool palette.
5. Set any or all axis you want aligned.
6. Click OK to apply or click Cancel to abort.

Align Options:

X Center - Sets the x-axis alignment factor.
Y Center - Sets the y-axis alignment factor.
Z Center - Sets the z-axis alignment factor.
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Control > Park [u]
Applies all transformations and deformations and locks them into the object. The object
center is reset to 0, its scaling is reset to 1 and its rotation is reset to 0. The model will still
look the same, but may react differently.

1. Select the object which you want to park.
2. Click Control in the main tool palette.
3. Click Park in the lower tool palette.
4. Th object is now parked, and all rotations, transformations and deformations have

been applied.

Park Options:

Park Offsets - Applies all position offsets to the objects’ mesh and resets the object’s
positions to 0.0.

Park Rotations - Applies all rotations to the objects’ mesh and resets the object’s
rotations to 0.0.

Park Scales - Applies all scaling factors to the objects’ mesh and resets the object’s
scales to 1.0.
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Control > Link/Unlink [o]
Applies a hierarchical (parent /child) grouping to objects so that they operate

together but can retain their individual rotation and scale values. If a link has
already been established, this tool breaks the hierarchical grouping of objects so
that they operate independently once again.

1.  Select the object(s) to be linked.
2.   Shift + select the target object. This object should be highlighted in green. If it

isn't, deselect everything and go to step 1.
3.  Click Control in the main tool palette.
4.  Click Link/Unlink in the lower tool palette.
5.  To Unlink, hold option down click Link/Unlink in the lower tool palette.

Link Options Options:

Scale - Inherit scaling factors from parent.
Rotation - Inherit rotational factors from parent.
Position - Inherit x, y, and z offset from parent.
Texture - Inherit all shader parameters from parent.
Lattice - Inherit lattice deformations from parent. (If the parent is linked to a

lattice).
Boolean - Sets whether or not this object will effect its parent at rendering time.
Union - Renders the parent and child objects as though they were one. 
Intersection - Renders only the overlapping portions of the parent and child.
Difference - Carves out or subtracts the child from the parent when rendering.
Smooth Seams - Enables Fusion™, Pixels proprietary seam smoothing technology,

hiding the visible ridges created when non-continuous surfaces
intersect.

Range - Sets the size of the Fusion™ blending.
Intersections - Intersecting objects are smoothed. When this is active, the Range

parameter is assumed to be in world space.
Edges - The edges of the smoothed objects are blended into the parent object.

When this is active, the Range parameter is assumed to be in st
(parameter) space.
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Control > Look/Unlook [p]
Creates a hierarchy which forces one object to always face toward another object. If such a
hierarchy has already been established, this tool breaks the hierarchical grouping of objects
so that they operate independently once again.

1.  Select the object(s) to be looked at.
2.   Shift + select the target object. This object should be highlighted in green. If it

isn't, deselect everything and go to step 1.
3.  Click Control in the main tool palette.
4.  Click Look/Unlook in the lower tool palette.
5.  To Unlook, hold option down click Look/Unlook in the lower tool palette.
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Control > Path/Unpath [Q]
Creates a hierarchy which links an object to a spline, using that spline as the object’s motion
path. If such a hierarchy has already been established, this tool breaks the hierarchical
grouping of objects so that they operate independently once again.

1.  Select the object(s) to be pathed.
2.   Shift + select the target object. This object should be highlighted in green. If it

isn't, deselect everything and go to step 1.
3.  Click Control in the main tool palette.
4.  Click Path/Unpath in the lower tool palette.
5.  To Unpath, hold option down click Path/Unpath in the lower tool palette.
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Control > Instance [W]
Duplicates a selected object across the surface of a target object. One copy is created for and
aligned with each vertex on the target object.

1. Select the object to be duplicated.
2.   Shift select the target object.
3. Click Control in the main tool palette. 
4. Click Instance in the lower tool palette.
5. Set any desired options.
6. Click OK to apply or click Cancel to abort.

Instance Options:

Rotate - When instancing, rotate each duplicate as described below.
Align With
Normal - The duplicates are rotated so that their z-axis’ are aligned with the

target object’s vertex normals.
Random - Using a fractal noise, each duplicate is randomly rotated. This is a good

option for simulating natural elements such as leaves on trees.
Make Group - All instanced objects will be linked to a newly created null object.

A cone instanced onto a sphere
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Control > Copy Shader [E]
Copies the Shader definition from one object to another.

1. Select the object(s) you want to inherit the shader.
2.  Shift + select the object whos shader you want to copy. This object should be

highlighted in green. If it isn't, deselect everything and go to step 1.
3. Click Control  in the main tool palette.
4. Click Copy Shader in the lower tool palette.
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Control > Copy Shape [R]
Copies the Shape geometry from one object to another.

1. Select the object(s) you want to inherit the shape.
2.  Shift + select the object whos shape you want to copy. This object should be

highlighted in green. If it isn't, deselect everything and go to step 1.
3. Click Control  in the main tool palette.
4. Click Copy Shape in the lower tool palette.
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Reshape > Push/Pull [a]
Use to grab any point or column on the mesh and drag it into a new shape.

1. Select the object you want to reshape.
2. If desired, adjust the flexibility or tension of the object (see Flex in the Window

menu). The area of effect can be limited using the tag option. Only tagged points
will be altered if the tag option is invoked.

3. Click Reshape in the main tool palette. 
4. Click Push/Pull in the lower tool palette.
5. Click on the vertex you want to move.
6. Drag with the mouse to push and pull that vertex into a new form.
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Reshape > Spline [s]
Uses the central Beziér curve present in every PiXELS:3D object to bend and reshape that
object.

1. Select an object to deform.
2. Click Reshape in the main tool palette. 
3. Click Spline in the lower tool palette. With a color monitor, the spline of the

selected object will appear in red. 
3. Click on any of the spline’s 4 control points and drag to bend and curve the

object along its backbone.
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Reshape > Pinch [d]
Constricts all the points in the current v step by pulling them toward their absolute center.

1. Select the object you want to pinch.
2. If desired, adjust the flexibility or tension of the object (see Flex in the Window

menu).
2. Click Reshape in the main tool palette. 
3. Click Pinch in the lower tool palette.
4. Click on any vertex in the v step you want to pinch. Use the V Col constraint to

help you see which points will be pinched.
5. Drag the mouse up to bulge the points out, or drag down to pinch the points in.
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Reshape > Subdivide [f]
Divides a patch to create a more detailed, smoother, higher resolution object.

1. Select the object you want to subdivide.
2. Click Reshape in the main tool palette. 
3. Click Subdivide in the lower tool palette.
4. Enter values for U Step and V Step. 
5. Click OK to apply or Cancel to abort.

Subdivide Options:

U Step - Sets the number of intermediate points to add between each u step.
V Step - Sets the number of intermediate points to add between each v step.
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Reshape > Collide [g]
Provides the ability to push one object into or out of another to create dents and bumps.

1. Use the Control tools to line up the two objects to prepare for collision. 
2. Selct the objects that you want to effect the final shape:  shift>select the first

object and  shift>select additional objects.
3. The last object selected with  shift will be the object you want to bump

or dent.
4. Click Reshape in the main tool palette. 
5. Click Collide in the lower tool palette.
6. Make the desired changes to the Collide Options parameters.
7. Click OK to collide or Cancel to abort. 

Collide Options:

Add - Causes the collision to happen from the inside, pushing outward.
Subtract - Causes the collision to happen from the outside, pushing in.
Subdivide - When selected, causes the object being collided with to subdivide

before collision detection. This provides a more accurate representation
of the colliding shape, but takes longer to calculate and returns a more
complex model.

Delete B - Discards the colliding object (the object used to make the dent) upon
return.
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Reshape > Join [h]
Bonds two objects together. Objects need the same number of points along the bonding axis
to be joined. 

1. Use the Control tools to line up the two objects to prepare for joining.
2. Select the first object you want to join. Select the object on the end you want

joined.
3.   shift select  the object you want to join. Make sure you click on the end you

want joined when selecting the second object..
4. Click Reshape in the main tool palette. 
5. Click Join in the lower tool palette.
6. Set the desired parameters.
7. Click OK to join or Cancel to abort. 

Join Options:

V to V - Joins the two selected objects while maintaining the step count of the v-
axis.

U to U - Joins the two selected objects while maintaining the step count of the u-
axis.
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Reshape > Insert [j]
Adds a column of control points along the u and/or v-axis. 
1. Select the object you want to insert points on.

Inserted column of points will be between the currently selected point and the
next point in line.

2. Click Reshape in the main tool palette. 
3. Click Insert in the lower tool palette.
4. Set the desired parameters.
5. Click OK to insert or Cancel to abort. 

Insert Options:

U Insert - Adds a column of points along the object’s u-axis. The number
represents where the new column will lie between the current column
and the next column in the patch.

V Insert - Adds a column of points along the object’s v-axis. The number
represents where the new column will lie between the current column
and the next column in the patch.
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Reshape > Remove [k]
Removes a column of control points along the u and/or v-axis. 

1. Select the object you want to effect.
2. Click on a point in the column you want removed.
3. Click Reshape in the main tool palette. 
4. Click Remove in the lower tool palette.
5. Set the desired parameters.
6. Click OK to remove or Cancel to abort. 

Remove Options:

U Remove - Removes a column of points along the object’s
u-axis.

V Remove - Removes a column of points along the object’s
v-axis.
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Reshape > Flip [l]
Reverses the object across the x, y or z plane.
1. Select the object you want to flip.
2. Click Reshape in the main tool palette. 
3. Click Flip in the lower tool palette.
4. Set the desired parameters.
5. Click OK to flip or Cancel to abort. 

Flip Options:

Global Coordinates - Flips the object’s position values as well as the geometry.
X Axis - Flips the object on its x-axis.
Y Axis - Flips the object on its y-axis.
Z Axis - Flips the object on its z-axis.

Stitch - Connects the original with the flipped state, creating a symmetrical
object.

U to U - Connects the shapes along the U axis.
V to V - Connects the shapes along the V axis.
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Reshape > Disrupt [A]
Randomly displaces every vertex on the selected patch. 

1. Select the object you want to disrupt.
2. Click Reshape in the main tool palette. 
3. Click Disrupt in the lower tool palette.
4. Set the Disrupt Options parameters.
5. Click OK to disrupt or Cancel to abort. 

Disrupt Options:

X - Sets the maximum displacement factor for X.
Y - Sets the maximum displacement factor for Y.
Z - Sets the maximum displacement factor for Z.
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Reshape > Invert [S]
Reverses the surface normals.

1. Select the object you want to invert.
2. Click Reshape in the main tool palette. 
3. Click Invert in the lower tool palette.
4. The object’s normals are now inverted. Use the Window > View > Normals

( /) menu item to view the normals.
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Reshape > 3D Emboss [D]
Uses the luminance values from any PICT image to displace the selected patch.

1. Select the object you want to emboss.
2. Click Reshape in the main tool palette. 
3. Click 3 D Emboss in the lower tool palette.
4. Set the 3 D Emboss Options parameters.
5. Click OK to emboss or Cancel to abort. 

3 D Emboss Options:

Image Box - Displays the current PICT image. If none is selected, this box will display a
message stating so. Click on this box to load a PICT image.

Displacement - The offset factor. This number is multiplied by the luminance of the
displacement map at any given pixel to factor how far to offset each vertex.
The luminance values are read as decimals ranging from 0 for pure black to
1 for pure white.

XY Mapping - Maps the x to u and y to v.
YX Mapping - Maps the y to u and x to v.
Displace Normals - Displacement will follow the surface normal.
Displace XYZ - Displacement will follow the selected axis.
X - Allows displacement along the x-axis.
Y - Allows displacement along the y-axis.
Z - Allows displacement along the z-axis.
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Reshape > Clip [F]
Removes any portion of the selected object which lies in the negative coordinate area of a
selected axis. 

1. Select the object you want to clip.
2. If necessary, rotate or move the object so that the part of the object you want to

trim off is positioned in the negative half of the coordinate axis you are going to
use for clipping.

3. Click Reshape in the main tool palette. 
4. Click Clip in the lower tool palette.
5. Set the axis you want to clip using the check boxes in the Clip Options dialog.
6. Click OK to clip or Cancel to abort.

Clipping Options:

Clip X - Clips any portion of the selected model which lies below 0 along the x-
axis.

Clip Y - Clips any portion of the selected model which lies below 0 along the y-
axis.

Clip Z - Clips any portion of the selected model which lies below 0 along the z-
axis.
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Reshape > Close Ends [G]
Adds flat or rounded end caps to the open sides of a selected object.

1. Select the object you want to close.
2. Click Reshape in the main tool palette. 
3. Click Close Ends in the lower tool palette.
4. Set the Close Ends Options parameters.
5. Click OK to close or Cancel to abort. 

Close Ends Options:

Sharp Edge - Sets the angle between the end cap and object at 90°. For B-Splines
and NURBs this option also doubles-up the vertices at the corner to
sharpen it.

Smooth Edge - Sets the angle between the end cap and object at 45°. Also takes into
account the Radius parameter when factoring edge smoothness.

Radius - Sets the distance between the rounding vertices. The distance is equal
to Radius multiplied by the distance to the end cap’s center. Vertices
closest to the end cap are moved in by this amount, all other rounding
vertices are moved back by
this amount.
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Reshape > Optimize [H]
Streamlines planar surfaces by removing redundant vertices that do not affect the object’s
geometry.

1. Select the object you want to optimize.
2. Click Reshape in the main tool palette. 
3. Click Optimize in the lower tool palette.
4. The computer will display a progress bar to let you know it’s working. When it’s

done, the model will be optimized.
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Reshape > Re-Order [J]
Recreates the existing spline as closely as possible using the desired number of vertices.

1. Select the spine you want to re-order.
2. Click Reshape in the main tool palette. 
3. Click Re-Order in the lower tool palette.
4. Set the desired options and click OK to accept or Cancel to abort.

Reorder Options

Steps - Sets the number of vertices the resulting spline will have.
Uniform Spacing - The resultant spline will have evenly spaced vertices.
Random Spacing - The resultant spline will have randomly spaced vertices.
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Reshape > Sculpt
Interactively paint surface deformations directly onto a selected object.

To use a Wacom Intuos Tablet with PiXELS:3D you will need to have the "Wacom Tablet"
control panel version 4.2.0 or later in the "Control Panels" folder of the System folder of the
startup disk of your Macintosh.  Other tablets may work, but they have not been tested by
Pixels.

The Wacom tablet is particularly useful with the PiXELS:3D "Sculpt" tool.  Note that you
must have the Studio version of PiXELS:3D to use the Sculpt tool.  If you have the Standard
version, the Sculpt tool will not appear in the tool palette.

When you select the Reshape>Sculpt tool, you will see the "Sculpt Options" dialog box.
Along the right side of the dialog are a series of check boxes that control how the pen
affects the Sculpt tool.  The sliders for "Size", "Softness", and "Pressure" set the maximum
values for each of those parameters when using the tablet.  In other words they set the
sensitivity of the pen for those parameters.  When the "Angle" checkbox is checked, the
angle of the pen modifies the base angle selected in the radio buttons to the left: "Screen"
or "Normal".  If "Screen" is selected the base angle is perpendicular to the screen.  If
"Normal" is selected the base angle is perpendicular to the object surface.

To use the Sculpt tool:

• Position the cursor over a selected object in the Camera view
• Depress the mouse switch (by depressing the pen or holding down the pen

button, depending on how you’ve set up the "Wacom tablet" control panel).
• Move the pen around the area you want to affect.  The Sculpt tool doesn’t do

anything when it is not moving.

When you are interacting with the Sculpt tool, the selected object is drawn at a lower
resolution to allow more responsive interaction.  After each use of the Sculpt tool the object
is redrawn at full resolution. If "Push" or "Pull" is selected at the bottom of the Sculpt
Options dialog, you can turn the pen over and use the eraser to perform the opposite action.
The same is true for the "Wrap In" and "Wrap Out" options.  These allow you to use the pen
to selectively control the Wrap tool described above.
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Shape > Cylinder [1]
A straight spline rotated 360° around an axis.

1. Click Shape in the main tool palette. 
2. Click Cylinder in the lower tool palette.
3. Name the object. Naming objects makes them easier to select from the

command line. This is nice when dealing with a large scene.
4. Set the U Step, V Step, Revolution, Radius and Length (z) parameters as

desired.
5. Click OK to create the shape, or click Cancel to abort.

Cylinder Options:

U Step - The number of vertices circling the cylinder. A higher value makes the
cylinder rounder but may take longer to redraw and render. The
minimum number is 3.

V Step - Represents the number of rings this cylinder will have. A value of 1 will
create a circle.

Revolution - How far to spin the spline which will form the cylinder. 360° represents a
full, closed cylinder.

Radius - The width (x) and height (y) of the finished cylinder.
Length (z) - The depth (z) of the finished cylinder.
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Shape >  Sphere [2]
A semi-circular spline which has been rotated 360° around an axis.

1. Click Shape in the main tool palette. 
2. Click Sphere in the lower tool palette.
3. Name the object. Naming objects now makes them easier to select from the

command line. This is nice when dealing with a large scene.
4. Set the U Step, V Step, Revolution U, Revolution V and Radius parameters

as desired.
5. Click OK to create the shape, or click Cancel to abort.

Sphere Options:

U Step - The number of vertices circling the sphere. A higher value makes the
sphere smoother but may take longer to redraw and render. The
minimum number is 3.

V Step - Represents the number of rings this sphere will have. The minimum
number is 2.

Revolution U - 360 degrees forms a full sphere.
Revolution V - 180 degrees forms a full sphere from top to bottom.
Radius - The width (x) and height (y) and depth (z) of the finished sphere.
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Shape > Cone [3]
A cylinder with the x and y axis scaled down to a point at one end.

1. Click Shape in the main tool palette. 
2. Click Cone in the lower tool palette.
3. Name the object. Naming objects now makes them easier to select from the

command line. This is nice when dealing with a large scene.
4. Set the U Step, V Step, Revolution, Radius and Length (z) parameters as

desired.
5. Click OK to create the shape, or click Cancel to abort.

Cone Options:

U Step - The number of vertices circling the cone. A higher value makes the
cone rounder but may take longer to redraw and render. The minimum
number is 3.

V Step - Represents the number of rings this cone will have. The minimum
number is 2.

Revolution - How far to spin the spline which will form the cone. 360° represents a
full, closed cone.

Radius - The width (x) and height (y) of the finished cone.
Length (z) - The depth (z) of the finished cone.
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Shape > Mesh [4]
A flat plane which can be formed into a 3 D shape by pushing and pulling its points.

1. Click Shape in the main tool palette. 
2. Click Mesh in the lower tool palette.
3. Name the object. Naming objects now makes them easier to select from the

command line. This is nice when dealing with a large scene.
4. Set the U Step, V Step, Width (x) and Length (z) parameters as desired.
5. Click OK to create the shape, or click Cancel to abort.

Mesh Options:

U Step - The number of vertices along the u-axis The minimum number is 2.
V Step - The number of vertices along the v-axis. The minimum number is 2.
Width (x) - The width (left to right) of the finished mesh.
Length (z) - The depth (front to back) of the finished mesh.
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Shape > Cube [5]
A six sided solid block.

1. Click Shape in the main tool palette. 
2. Click Cube in the lower tool palette.
3. Name the object. Naming objects now makes them easier to select from the

command line. This is nice when dealing with a large scene.
4. Set the U Step, V Step, Width (x), Height (y) and Length (z) parameters as

desired.
5. Click OK to create the shape, or click Cancel to abort.

Cube Options:

U Step - The number of vertices along the u-axis The minimum number is 4.
V Step - The number of vertices along the v-axis. The minimum number is 1.
Width (x) - The width (left to right) of the finished cube.
Height (y) - The height (top to bottom) of the finished cube.
Length (z) - The depth (front to back) of the finished cube.
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Shape > Spline [6]
The most basic primitive. This is the building block upon which all other shapes are based.

1. Click Shape in the main tool palette. 
2. Click Spline in the lower tool palette.
3. Click in any window to enter drawing mode and start drawing. The first click

defines the position of the first vertex. Each subsequent click will define the next
vertex in line.

4. Double click to add the last vertex and exit drawing mode, or click on the first
vertex to close the shape and exit drawing mode.

5. Use Window > Object Info to name the object. Naming objects now makes
them easier to select from the command line. This is nice when dealing with a
large scene.
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Shape > Extrude [7]
Pulls a 2-D spline into 3 D space along a pre-defined axis.

1. Select the spline to be extruded. 
2. Click Shape in the main tool palette. 
3. Click Extrude in the lower tool palette.
4. Set the Extrude Options parameters as desired.
5. Click OK to create the shape, or click Cancel to abort.

Extrude Options:

Step - The number of vertices along the v-axis The minimum number is 2.
Depth - The depth (front to back) of the finished object.
Bevel - Creates a 45° edge between both faces and the extruded object. This

option will add v-steps to the finished object if needed. 
Radius - How far the bevel pushes the surface out. A negative number will push

the bevel inward.
Height - How far the bevel will extrude from the current face.
Front Beveling- Place a bevel on the front face of the extruded object.
Back Beveling- Place a bevel on the back face of the extruded object.
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Shape > Lathe [8]
Spins a 2-D spline around the y-axis to create a new 3 D shape.

1. Select the spline to lathe. The spline must be drawn in the front or right window.
The revolution is made around the y-axis.

2. Click Shape in the main tool palette. 
3. Click Lathe in the lower tool palette.
4. Set the Lathe Options parameters as desired.
5. Click OK to create the shape, or click Cancel to abort.

Lathe Options:

Step - The number of vertices along the u-axis The minimum number is 4. The
higher this number, the rounder the final shape will appear.

Degree - The spline will revolve (counter clockwise) the number of degrees set
around the y-axis.

Close - Closes the object ends.
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Shape > Loft [9]
Creates a 3 D object from a collection of splines defining “slices” of the object.

1. Draw or import a collection of splines representing different “slices” of the object
(splines must contain the same amount of vrticies).

2.  select the first spline.
3.  Shift + select each additional slice, in order as they are to be lofted.
4. Click Shape in the main tool palette. 
5. Click Loft in the lower tool palette.
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Shape > Light [0]
Places a light source in the scene and sets its intensity. Any number of lights may be placed
in a scene, and each can be colored and moved.

1. Click Shape in the main tool palette. 
2. Click Light in the lower tool palette.
3. Use the Control > Move tool to place the object anywhere in the scene.
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Shape > IK chain [!]
Allows you to draw kinematic chains. There is no limit to the number of joints allowed in a
single chain.

1. Click Shape in the main tool palette. 
2. Click IK Chain in the lower tool palette.
3. Click in any window to enter drawing mode and start drawing. The first click

defines the position of the first joint. Each subsequent click will define the next
joint in the chain.

4. Double click to add the last joint and exit drawing mode.
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Shape > Lattice [@]
A special primitive which resembles a cube. The lattice defines an area in 3 D space. This
area can be deformed by reshaping the lattice. Any point on any object linked to this lattice,
which falls within this lattice, will be remapped to the lattice’s deformed 3 D space.

1. Select the object you want to create a lattice around.
2. Click Shape in the main tool palette. 
3. Click Lattice in the lower tool palette.
4. Set the Lattice Options parameters as desired.
5. Click OK to create the lattice, or click Cancel to abort.

Lattice Options:

U Step - The number of subdivisions this lattice will have left to right and top to
bottom.

V Step - The number of subdivisions this lattice will have front to back.
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Shape > Extract [$]
Copies the currently selected u-col or v-col and pastes it into the scene, creating a new 2-D
spline.

1. Select the object and col to extract.
2. Select either U-Col or V-Col constraint. If neither is selected V-Col is assumed.
3. Click Shape in the main tool palette.
4. Click Extract in the lower tool palette.
5. The selected u-col or v-col will be extracted and become the currently selected

object.
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Shape > Path extrude [%]
Creates a 3 D object by projecting one spline along another spline which is used as a path.

1. Select the object to extrude.
2.   shift select the path.
3. Click Shape in the main tool palette.
4. Click Path Extrude in the lower tool palette.
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Shape > Null [&]
Creates a simple primitive which represents a position in space. A null does not show up
when rendered.

1. Click Shape in the main tool palette.
2. Click Null in the lower tool palette.
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Shape > 4-Side Blnd [(]
Uses four user defined boundary curves to interpolate a patch.

1. Use the Spline tool to draw four boundary curves. The number of steps need not
be the same in any of the splines, but the direction of the opposing curves
(front/back and left/right) should be the same. If not, the resultant shape will have
a twist.

2. Arrange the curves such that they define a boundary. The corners need not
touch, but the closer they are the better.

3. Select the four boundary curves, making sure to select them in clockwise order.
4. Click Shape in the main tool palette.
5. Click 4-Side Blnd in the lower tool palette.
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Shape > Trim Surface
Converts a 2D spline drawn in the front (xy) view into a renderable surface with the same
shape as the original spline. If additional 2D splines are linked to the spline being trimmed,
they will be incorporated into the trim surface as well.

1. In the front view, draw a spline. If you prefer, splines can be imported from
Adobe Illustrator.

2. With the spline selected, click Shape in the main tool palette.
3. Click Trim Surface in the lower tool palette.
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Shape > Microscribe
Works with the Microscribe digitizer from Immersion.

1. Make sure your digitizer is properly connected to your machine.
Note: you must be connected to the modem port.
2. Click Shape in the main tool palette.
3. Click Microscribe in the lower tool palette.
4. In the camera view, a null object should be visible.
If not, dolly out until it is visible. 
This null object represents the tip of the digitizer.
5. Position the digitizer on the first point to digitize.
6. Press the space bar to insert a point.
7. Position the digitizer on the next point to digitize.
8. Repeat steps 6 & 7 until all points on this cross section have been digitized.
9. Press the enter key to finish a cross section.
10. Move to the next cross section.
11. Repeat steps 5 - 10 until all cross sections have been entered.
12. Hit the escape key to return to normal modeling mode.
13. Loft the cross sections.
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Pencil Test [,]
Renders a B&W wireframe (depending on which Shaded Preview options are selected) of all
the frames in an animation, then plays them back in real time.

1. Create an animation.
2. Click Animate in the main tool palette.
3. Click Pencil Test in the lower tool palette.
4. Set the frame range and step rate in the Pencil Test Options dialog. Click

OK.
5. The computer will render each frame, one by one. When it is done, it will play

them back at full speed.`
6. To stop playback, click the mouse.
7. To scrub through frames, hold down the mouse and move left to rewind or right

to fast forward.

Pencil Test Options:

From - First frame in the Pencil Test Animation.
to - Last frame in the Pencil Test Animation.
Step - Forces renderer to draw every nth frame.
fps - Sets the number of frames displayed per second.
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Offset Keys [+]
Moves all keyframes for the current object or all objects in a scene.

1. Select an object.
2. Click Animate in the main tool palette.
3. Click Offset Keys in the lower tool palette.
4. Enter an offset value and a frame range. To alter all objects in a scene, enable

the All objects option. Click OK to accept or click Cancel to abort.
5. All keyframes for the current object, or all objects, between the inpoint and the

outpoint will be offset by the value defined.

Offset Keys Options:

Frame range - Defines a range of frames which this function will effect.
Offset - Defines an offset which the keyframes’ position in time will be offset by.
All objects - When enabled, forces the function to effect all objects in a scene.

174

PiXELS:3D v e r s i o n  3 . x

a
n
i
m
a
t
e

t
o
o
l
s



Invert Keys [<]
Flips all keyframes for the current object or all objects in a scene.

1. Select an object.
2. Click Animate in the main tool palette.
3. Click Invert Keys in the lower tool palette.
4. Enter a frame range. To alter all objects in a scene, enable the All objects option.

Click OK to accept or click Cancel to abort.
5. All keyframes for the current object, or all objects, between the inpoint and the

outpoint will be inverted.

Invert Keys Options:

Frame range - Defines a range of frames which this function will effect.
Centered on - Defines a pivot point around which the keyframes will be flipped.
All objects - When enabled, forces the function to effect all objects in a scene.
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Scale Keys [-]
Scales all keyframes for the current object or all objects in a scene.

1. Select an object.
2. Click Animate in the main tool palette.
3. Click Scale Keys in the lower tool palette.
4. Enter a scale factor value and a frame range. To alter all objects in a scene,

enable the All objects option. Click OK to accept or click Cancel to abort.
5. All keyframes for the current object, or all objects, between the inpoint and the

outpoint will be scaled by the value defined.

Scale Keys Options:

Frame range - Defines a range of frames which this function will effect.
Centered on - Defines a reference frame for scaling.
Scale - Defines a scaling factor which the keyframes’ position in time will be

scaled by. (i.e. a value of 0.5 = 50%)
Ripple All frames after the last frame scaled will be offset such that they remain

sequenced with this last frame.
All objects - When enabled, forces the function to effect all objects in a scene.
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Dup. Keys... [>]
Used to duplicate a set of keyframes for action that repeat in an animation.

Duplicate Keys Options

Frame range From To - Specifies the range of frames from which keyframes are
copied.

# of copies - How many copies to make.
Offset - If offset is zero, copies will be appended to the existing function curve. If

some non-zero value is specified for Offset, each copy will be shifted
forward that number of frames.

All Objects - Copy keyframes for all object or just the selected one.
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View PICT
A simple utility which allows you to quickly preview any PICT image.

1. Click Utility in the main tool palette.
2. Click View PICT in the lower tool palette.
3. Use the standard Open dialog which comes up to locate and select a PICT file.
4. Click the Open button to accept.
5. A window containing your selected image will appear centered on the main

screen.
6. Click in the image window to return to normal operation.
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View TIFF
A simple utility which allows you to quickly preview any 24bit TIFF image.

1. Click Utility in the main tool palette.
2. Click View TIFF in the lower tool palette.
3. Use the standard Open dialog which comes up to locate and select a TIFF file.
4. Click the Open button to accept.
5. A window containing your selected image will appear centered on the main

screen.
6. Click in the image window to return to normal operation.
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View PICTS
A simple utility which allows you to load and playback a series of PICT frames.

1. Click Utility in the main tool palette.
2. Click View PICTs in the lower tool palette.
3. Use the standard Open dialog which comes up to locate and select a the first

frame of your animation. NOTE: the file name must match standard PiXELS:3D
file naming conventions for sequentially numbered PICTs - file name.#####.

4. Click the Open button to accept.
5. A window containing your selected image will appear centered on the main

screen. Each frame in turn will be loaded and displayed. After all frames have
been loaded into memory they will be played back at the speed set under File >
Render Setup.

6. To stop playback, click the mouse.
7. To scrub through frames, hold down the mouse and move left to rewind or right

to fast forward.
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Render Texture
Allows complex procedural Shaders to be rendered out to uv maps which can then be
applied to the model.

1. Click Utility in the main tool palette.
2. Click Render Tex in the lower tool palette.
3. Set the desired options.
4. Click the OK to accept or Cancel to abort.

Render Texture Setup Options:

Shader Component - A pop up menu which lists all the base ShaderMaker nodes. Any
one of these can be rendered out.

Auto Apply - After rendering, the uv map is loaded into memory and applied to the
selected Shader component. Note: the procedural shader used to
render this map will be overwritten. If you wish to keep this, the Shader
must be saved first.

Texture Size - The size, in pixels, of the resultant texture map.
Texture Name - The file name given to the resultant texture map.

The Render Texture  tool has many uses. When dealing with complex Shaders, this tool can
be called upon to create a texture map which renders much faster than a procedural Shader.
If a procedural Shader is being used on an object with an animated deformation, the Shader
may appear to slide through the object. Rendering a uv map resolves this problem.
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Reset Schematic
If you have moved objects around in the Schematic view, this command restores them to
their original positions.
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Point [Z]
Puts the Push/Pull tool into single point mode. The scene will reflect this by highlighting
only the point currently selected.

1. Click Point in the Constraints palette.

U col [X]
Puts the Push/Pull tool into U Col mode. The scene will reflect this by highlighting the point
currently selected and all points sharing that point’s u-step. This tool can help orient you if
you’re having trouble seeing the difference between u and v.

1. Click U Col in the Constraints palette.

V col [C]
Puts the Push/Pull tool into V Col mode. The scene will reflect this by highlighting the point
currently selected and all points sharing that point’s v-step. This tool can help orient you if
you’re having trouble seeing the difference between u and v. It can also be useful in
conjunction with the Reshape > Pinch tool to help you visualize which points will be
pinched.

1. Click V Col in the Constraints palette.
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Mir U [V]
Mirrors all Push/Pull deformations across the u-axis to help in the creation of symmetrical
shapes. NOTE: If a shape has an uneven number of u-steps or if you have inserted u-steps on
one side of a model and not the other, this tool will not work properly. The starting shape
MUST be symmetrical to get predictable results.

1. Click Mir U in the Constraints palette.

Mir V [B]
Mirrors all Push/Pull deformations across the v-axis to help in the creation of symmetrical
shapes. NOTE: If a shape has an uneven number of v-steps or you have inserted v-steps on
one side of a model and not the other, this tool will not work properly. The starting shape
MUST be symmetrical to get predictable results.

1. Click Mir V in the Constraints palette.

Mir UV [N]
Mirrors all Push/Pull deformations across an axis perpendicular to the
u-axis to help in the creation of symmetrical shapes.

1. Click Mir UV in the Constraints palette.
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X axis [z]
Turns the x-axis on or off. Objects can only be transformed along axes that are “on” (their
buttons are pushed in). Works in conjunction with the control tools to constrain movement.

1. Click X Axis in the Constraints palette.

Y axis [x]
Turns the y-axis on or off. Objects can only be transformed along axes that are “on” (their
buttons are pushed in). Works in conjunction with the control tools to constrain movement.

1. Click Y Axis in the Constraints palette.

Z axis [c]
Turns the z-axis on or off. Objects can only be transformed along axes that are “on” (their
buttons are pushed in). Works in conjunction with the control tools to constrain movement.

1. Click Z Axis in the Constraints palette.
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Tag [v]
Sets the transformation selection mode to points rather than object.

1. Click Tag in the Constraints palette.
2. Hold down the  key and click on any point to select it.

OR hold down the  key and click and drag a rectangle around any points you
want selected.
OR hold down the +shift keys and click on any point to toggle it. (If it’s
selected, it will become deselected. If it’s deselected it will become selected.)
OR hold down the +shift and click and drag a rectangle around any points you
want toggled.

3. Use any of the transformation tools to scale, move or rotate the selected points.

OR use the File > Export > Tag Map (PICT) tool to create a 2-D image of the surface for
texture map creation. (See File > Export > Tag Map (PICT) for more info.)

The Tag tool will only work when the Control tool group is selected. To select points on
objects other than the currently selected object, add the option key to any key combination
listed above.
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Glossary
Align specified parameters. In PixelPutty, objects are aligned with their
center points.

Bevel The detailing of small angles where edges meet to soften and
appearance of the model. Bevels are also used to catch and reflect light.

Bezier spline Defines a curved surface by interpolating the first and last
control points along with the inner two points governing the curve’s
direction.

Bias The symmetry of the spline near a control point. A very biased curve
will be flatter on one side than the other.

Clipboard A temporary storage area on the computer to hold the last item
that was cut or copied from the model. The Clipboard is a standard feature
on all Macintosh computers.

COI Center of Interest. A point in 3D space which the camera looks at.

Control points Points on the surface of the object that determine the
underlying geometry of the object. The curve of a spline is determined by
four or more control points.

Default Commonly preferred options set at program startup. Defaults may
be manually changed.

Displacement Map The gray level information of any PICT image applied
to an object to deform its geometry.

DXF Drawing Exchange Format, a file format widely-used for architectural
drawings and other polygonal primitives.

Export Saving files in a different format for use with other software
applications.

Extrude The modeling process of pulling 2-D outlines or profiles into
3-D shapes.

Freeform Unique shapes that can be designed from drawn 2-D outlines.

Gouraud shading Rendering technique which varies brightness across
each surface polygon to produce a smooth appearance.

Grid The horizontal and vertical lines in the background that help place the
model in a perspective setting. The grid does not print.
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U Step Coordinate space along the horizontal plane of the surface mesh.

Hidden line Built-in rendering of the surface mesh of an object with
overlapped or obscured areas hidden.

Interpolation Calculation of intermediate points between specified
control points to approximate and smooth the distance between the end
points.

Keyboard shortcuts Keyboard equivalents that can be used as
alternatives to pull down menus and the mouse.

Lathe The modeling process of creating a 3-D object by revolving an
outline around an axis.

Loft Stretches a skin between 2-D shapes placed on a path to create a
new 3-D shape.

Menu bar The row of pull down menu names at the top of the screen.

Mesh The two-dimensional undersurface grid applied to the model for
shaping purposes.

NURBs Non-uniform rational B-splines which require an explicit
specification of the parameters that trace out the surface.

Photo realism A high level of realism accomplished by applying lights,
shading, and textures to the
3-D model.

Phong shading Rendering technique which produces shiny surfaces.

PICT A graphics file format used by many computer applications.
PixelPutty can export rendered images into PICT formats.

Primitives Common geometrical forms which are used as 3-D building
blocks to make more complex shapes.

Proxy An approximation of the skeletal structure of the model without all
the wireframe details. PixelPutty uses this feature to shorten redrawing time
as changes are made to the model.

Render The process of recalculating all the specified geometry and
drawing the model with highlights and shading, color, reflections,
refractions, texture and other surface qualities is called rendering. The
rendering process gives the 3-D model a finished look.
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Reshape Modifications and alterations to a model that affect its geometry.

RIB RenderMan Interface Bytestream protocol, the format generated and
required by MacRenderMan to render an image.

Screen refresh Redrawing the screen image after changes or new
commands are made.

Shader A procedural (mathematically-based) 3-D surface description.

Spline A curve that is defined by four control points.

Subdivisions the division of surface polygons into smaller polygons to
create a smoother finished appearance of the object.

Symmetry Changes to the model which affect the shape along the X and
Y axes equally.

Surface Normal A vector perpendicular to the plane of every surface
polygon used by the computer to calculate brightness, highlights,
reflections, and distortions of the model.

Texture mapping A two-dimensional pattern applied to or wrapped
around the surface of a three-dimensional computer-generated model.

Toggle Command Operates like an on/off switch. Click on it to enable and
click again to disable.

Tool Palette Modeling tools to shape, move and alter and manipulate 3-D
forms.

V Step Coordinate space along the vertical plane of the surface mesh.

Wireframe The undersurface skeletal structure of the model.

Z axis The coordinate used to determine the depth of a model.

3DGF 3-D Geometry File format that supports spline-based architecture but
does not carry shader information.
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